summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild')
-rw-r--r--gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild b/gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild
new file mode 100644
index 000000000000..9adc0c9dfb84
--- /dev/null
+++ b/gnome-extra/cinnamon-screensaver/cinnamon-screensaver-2.6.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="Screensaver for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-screensaver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc pam systemd"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=x11-libs/gtk+-3.1.4:3[introspection]
+ >=gnome-extra/cinnamon-desktop-2.6.3:0=[systemd=]
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ >=gnome-base/libgnomekbd-3.6
+ >=dev-libs/dbus-glib-0.78
+
+ net-libs/webkit-gtk:3[introspection]
+
+ sys-apps/dbus
+ x11-libs/libxklavier
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/libXxf86misc
+ x11-libs/libXxf86vm
+ x11-themes/gnome-icon-theme-symbolic
+
+ ${PYTHON_DEPS}
+
+ pam? ( virtual/pam )
+ systemd? ( >=sys-apps/systemd-31:0= )
+"
+# our cinnamon-1.8 ebuilds installed a cinnamon-screensaver.desktop hack
+RDEPEND="
+ !~gnome-extra/cinnamon-1.8.8.1
+ !systemd? ( sys-auth/consolekit )
+
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/randrproto
+ x11-proto/scrnsaverproto
+ x11-proto/xf86miscproto
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.4 )
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.3-automagic-logind.patch
+
+ # Fix xscreensaver paths for gentoo
+ sed -e "s#/usr/lib/xscreensaver/#${EPREFIX}/usr$(get_libdir)/misc/xscreensaver/#" \
+ -i data/screensavers/xscreensaver@cinnamon.org/main || die
+
+ python_fix_shebang data/screensavers
+
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_enable doc docbook-docs) \
+ $(use_enable pam locking) \
+ $(use_enable systemd logind) \
+ --with-mit-ext \
+ --with-pam-prefix=/etc \
+ --with-xf86gamma-ext \
+ --with-kbd-layout-indicator
+ # Do not use --without-console-kit, it would provide no benefit: there is
+ # no build-time or run-time check for consolekit, $PN merely listens to
+ # consolekit's messages over dbus.
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version x11-misc/xscreensaver; then
+ elog "${PN} can use screensavers from x11-misc/xscreensaver"
+ fi
+}