summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2018-04-02 19:20:59 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2018-04-02 20:36:01 +0200
commit8f947b8fa11d7a4e5532702da94249dd88e0d27b (patch)
tree35c3885d5f779ca737aafb2e445c31861e8f22dd /gnome-extra/cjs/cjs-3.6.1.ebuild
parentxfce-extra/transd: remove obsolete xfconf.eclass, migrate to EAPI6, cleanup (diff)
downloadgentoo-8f947b8fa11d7a4e5532702da94249dd88e0d27b.tar.gz
gentoo-8f947b8fa11d7a4e5532702da94249dd88e0d27b.tar.bz2
gentoo-8f947b8fa11d7a4e5532702da94249dd88e0d27b.zip
gnome-extra/cjs: RESTRICT=test and fix a bunch of test failures
Fix a number of test failures related to console execution missing compat symlink. Down to 2 remaining errors, but this test suite is flaky enough and its not a reason to hold up the stabilization any longer so adding a RESTRICT=test for now Bug: https://bugs.gentoo.org/649534 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'gnome-extra/cjs/cjs-3.6.1.ebuild')
-rw-r--r--gnome-extra/cjs/cjs-3.6.1.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnome-extra/cjs/cjs-3.6.1.ebuild b/gnome-extra/cjs/cjs-3.6.1.ebuild
index 23afc9055f7d..d0ae7f565acc 100644
--- a/gnome-extra/cjs/cjs-3.6.1.ebuild
+++ b/gnome-extra/cjs/cjs-3.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,9 +34,23 @@ RDEPEND="${RDEPEND}
!<gnome-extra/cinnamon-2.4
"
+RESTRICT="test"
+
src_prepare() {
eautoreconf
gnome2_src_prepare
+ sed -ie "s/gjs-console/cjs-console/g" \
+ "${S}"/installed-tests/scripts/testCommandLine.sh \
+ "${S}"/installed-tests/scripts/testWarnings.sh || die
+
+ sed -ie "s/Gjs-WARNING/Cjs-WARNING/g" \
+ "${S}"/installed-tests/scripts/testCommandLine.sh || die
+
+ sed -ie "s/'Gjs'/'Cjs'/g" \
+ "${S}"/installed-tests/js/testExceptions.js \
+ "${S}"/installed-tests/js/testSignals.js \
+ "${S}"/installed-tests/js/testGDBus.js \
+ "${S}"/installed-tests/js/testEverythingBasic.js || die
}
src_configure() {