summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-11 12:22:51 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-11 12:56:02 -0800
commit159af4768825eeddc6b71573635123fe4b3943d7 (patch)
treeff9f343f2692e999c3912a7d0c08388dea8619ed /gnome-extra/evolution-ews
parentgnome-extra/evolution-data-server: Version bump to 3.42.4 (diff)
downloadgentoo-159af4768825eeddc6b71573635123fe4b3943d7.tar.gz
gentoo-159af4768825eeddc6b71573635123fe4b3943d7.tar.bz2
gentoo-159af4768825eeddc6b71573635123fe4b3943d7.zip
gnome-extra/evolution-ews: Version bump to 3.42.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.42.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 42dc5a8dc86a..a4755daefeef 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.40.4.tar.xz 673888 BLAKE2B 532b708795db3ffdff69b44d31c49ff9c4800b527b09d4440b383a16f6ad283cea5ebdfae5cf104e08d8f2166d7269d6810d4ae6ead2c55af7f77633292d7376 SHA512 7f89e8cebf5931bd7d2f636b1780d914f069fb62ac4e14ad0ab2c9759e4553bc5d58a53b65a635c7b5be298fc017f375f9ca4d1c96002804093b9f47107455f2
DIST evolution-ews-3.42.3.tar.xz 685692 BLAKE2B 6e9a06c78d54f119e0d942dc830d118fc7a0b19c16fa3729491b695ac01c582b1124d895d3f56ccadf72fca5716491f29a6ca6ac216fea2ea2cd1a26bdd3f5ed SHA512 e740796e4c4afc8946592195d21aac2171724cad6069001c7d2af36f1deb8d25f89ce825898faa9e042fb6e32571f7556579bf984da0573118739e314fb7bff9
+DIST evolution-ews-3.42.4.tar.xz 686236 BLAKE2B f68a3c4c41419eb5d316ce8271a8c8411217e63b951230fb0151d79fca15e82e36248e3bd676518ae5f8a92d7e1d1dbf6a140bbd63dee6dca97fe48f76d502f9 SHA512 5ce1a228414d8c456962ce944a01efbeefb059bc9ff358c95bb7cec72e74ad29cd9476c9aa396b01df35d7c89fff743837dc2f9763129a5f794cbbd14557c2e3
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.42.4.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.42.4.ebuild
new file mode 100644
index 000000000000..e3822dd52ce6
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.42.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}