summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-13 19:49:17 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-13 20:47:41 +0200
commitbcefe637ef9423f552b906bd29f70d703d4bcf4f (patch)
treee70499985434d911efd3a3779ddbf5a9cffb840f /gnome-extra/evolution-ews
parentmail-client/evolution: bump to 3.38.2 (diff)
downloadgentoo-bcefe637ef9423f552b906bd29f70d703d4bcf4f.tar.gz
gentoo-bcefe637ef9423f552b906bd29f70d703d4bcf4f.tar.bz2
gentoo-bcefe637ef9423f552b906bd29f70d703d4bcf4f.zip
gnome-extra/evolution-ews: bump to 3.38.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 155bfcff35df..dc279548753b 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.36.5.tar.xz 558900 BLAKE2B 059a72b087287d0e553e085dc764a928d838bc8bd011c16b00f240b29d12bc7cfda98d33f8dc102866f5747313975e32506dc016435342bdb6c35f7d73749b52 SHA512 9cc40ae5d56bc86a8aa4e7aaa36fa10b0841278dd1edb075155bfe3666da4051e4fc4843398f74d00d77f550aaeb93bf576007828da4c574a17d4f17c41bfb7f
+DIST evolution-ews-3.38.2.tar.xz 650188 BLAKE2B a1e296a15269191ecc9ff02108daed90bbcaefbabdc989f919dfc25532cb31a7afa73d897bcc0f2dbaf22b0e9b250af61db9900bc2dec740b08786dad7808e8b SHA512 5f441ecbf2753243711b605e085ae8fddcfaf0f91f822b76d8a8453aca0f55c2e7788d74d726651d58b97160db3581e269e6b9f05d7c4258bd28cf13ff14efe4
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild
new file mode 100644
index 000000000000..422d53389b60
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}