summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-06 19:00:35 +0200
committerMart Raudsepp <leio@gentoo.org>2020-05-08 10:22:00 +0300
commite8c3fccce2907d02bff924b3831437d0cb44ce25 (patch)
tree0ababfd210ea60e4cd830dd2758f50ff996b3f41 /gnome-extra/evolution-ews
parentmail-client/evolution: Bump to 3.36.2 (diff)
downloadgentoo-e8c3fccce2907d02bff924b3831437d0cb44ce25.tar.gz
gentoo-e8c3fccce2907d02bff924b3831437d0cb44ce25.tar.bz2
gentoo-e8c3fccce2907d02bff924b3831437d0cb44ce25.zip
gnome-extra/evolution-ews: Bump to 3.36.2
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.36.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index c8f26213e3b3..0fa3d4c56607 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1 +1,2 @@
DIST evolution-ews-3.34.4.tar.xz 538964 BLAKE2B 3b23dee72b13bd7da0efdacc13bf16052b52287dfbdeb913100244cfbdc726fdd6dc526fa38eb3da849ea5e9c95e9bb59fedadbe0238c37698cedefdda05f82d SHA512 397dd89c81c986501aaf5c0460735577ebe2aa0bfe549359073e211e912e3622c7ba61eb90898ec00a06bb1c4d02a565446a3b0620ff8515088d706d5c246c91
+DIST evolution-ews-3.36.2.tar.xz 552680 BLAKE2B de7b0d9155de895401d52ad4b82126f048c23ffe63d13e97505c9767f89d850d9e58e84ba26940835a066af4c53f78c465e015f6a473f052bdd6a7ffe18c9a10 SHA512 662828afa7eefec720016ec2d7c70fddd376c4a3ae974287516f7ce063c293665172fdbffa8a25333a0564b74632d8409140cac60f35cd3f169d063cecc337c8
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.36.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.36.2.ebuild
new file mode 100644
index 000000000000..b3b87637eb31
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.36.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+src_prepare() {
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}