summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-22 17:43:14 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-22 18:10:57 -0700
commitfd89360eae6d8d81d2651949099c2caf0dd6f632 (patch)
tree979fb2e7696586b0bdc1a4c19c5853460ee47aaa /gnome-extra/evolution-ews
parentmail-client/evolution: Version bump to 3.40.3 (diff)
downloadgentoo-fd89360eae6d8d81d2651949099c2caf0dd6f632.tar.gz
gentoo-fd89360eae6d8d81d2651949099c2caf0dd6f632.tar.bz2
gentoo-fd89360eae6d8d81d2651949099c2caf0dd6f632.zip
gnome-extra/evolution-ews: Version bump to 3.40.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.40.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index e8fde3b061f5..1f7d4845b05b 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.40.1.tar.xz 672448 BLAKE2B ac6548c2567dd1ca303def27a21974f93d44c1175e8474bebaa6576dc63f8624c32e9357186e2c1412ca2091412b17e0f244c60919652ede55fb77e1bb384b90 SHA512 8d0477b500ee1b0c6a9527f2d63fe0b4238862425a079729478a8df880f35e6a1166d2f8f77cafa73844351f0cffe171d857366c4527770d7436d8b4ace29b99
DIST evolution-ews-3.40.2.tar.xz 673592 BLAKE2B 0b11b77c729102ecc0602abde323817782b9d56939a708bf9a506f2dc2d9d0edb43f7607e0a970db3144965aa669691d2041d99841d70ac604feece721e11979 SHA512 a42f8ee092aa1fdfff07729bb1c3d0f80a25f6073f07135f0fecb8f431cd5273c2afd292752457515b0be71f106025d413948a97f2a4d3d43b049989dc296175
+DIST evolution-ews-3.40.3.tar.xz 673800 BLAKE2B 4d8cbce33552a40551db08f25bb784ec1b54df0672bab95cd278de6a761a0ed05d5d21754107043fcfde1b533edfbce6a25b2d7fc3c6e885bc7618efd8c89763 SHA512 c35da74f1c52dabf1d3373654a70a7fa005cbc8ebb30a64c3315cffae222221a049918eb9821773020a7178c64caac0b9360ea562eda748b1e26911fcb4fcb90
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.40.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.40.3.ebuild
new file mode 100644
index 000000000000..2088827c2022
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.40.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}