summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 12:45:16 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 12:45:16 -0400
commit73f308742ea53c9468056843d8a317d227297cc3 (patch)
tree10e3a9dc0e16822d5d4844acbf3b31105dfee8fe /gnome-extra/gnome-characters
parentsys-apps/xdg-desktop-portal-gnome: Version bump to 43.0 (diff)
downloadgentoo-73f308742ea53c9468056843d8a317d227297cc3.tar.gz
gentoo-73f308742ea53c9468056843d8a317d227297cc3.tar.bz2
gentoo-73f308742ea53c9468056843d8a317d227297cc3.zip
gnome-extra/gnome-characters: Version bump to 43.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-characters')
-rw-r--r--gnome-extra/gnome-characters/Manifest1
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-43.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/Manifest b/gnome-extra/gnome-characters/Manifest
index 7be7d30d169f..e3a522df76e5 100644
--- a/gnome-extra/gnome-characters/Manifest
+++ b/gnome-extra/gnome-characters/Manifest
@@ -1 +1,2 @@
DIST gnome-characters-42.0.tar.xz 561308 BLAKE2B 454d2bbdc5e8486f50b3f21bba4a65aa0920654c2cc3376cdda62070011c1a296f240632ddcd412add7953fccb2780ba37ac3196aef138e9771cdf5a81061441 SHA512 ba6fa07ff90ede1cba0e541f0c4bda63f1d6122c18af44dafa3bfb0fa6f9580a3cd8580d0a12510e2eb95afedb4b0f350accc37eee85c3aa4422a66732dff404
+DIST gnome-characters-43.0.tar.xz 582892 BLAKE2B 20ee1a5f12242797c2c12a0ed32d809210f059dc40d986eab754e966b40625eb90544fc494867969ca426f4b0891a378a22ace52d0a1bd641c803bdd75d4c4c2 SHA512 0bb86c7763b4930695f089a65723873ec736d78fd04b56cd54fa5785c62271e3490413232c6ebd27171855f125cd1732e7357ca819227f128efed057c1c8a8c4
diff --git a/gnome-extra/gnome-characters/gnome-characters-43.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-43.0.ebuild
new file mode 100644
index 000000000000..7d12676ca9a8
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-43.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libunistring-0.9.5:=
+ >=gui-libs/gtk-4.6:4[introspection]
+ >=gui-libs/libadwaita-1.2:1=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+ gnome-base/gnome-desktop:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}