summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUwe Scholz <uwescholz@src.gnome.org>2017-04-16 16:44:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 19:41:47 +0200
commit182efcb8fc6417291d26fd76e97ca8e8d788ad8d (patch)
treeb5aace48e69909c79b9a949c656d0705a725a6a4 /gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild
parentgames-strategy/endless-sky: version bump 0.9.6 (diff)
downloadgentoo-182efcb8fc6417291d26fd76e97ca8e8d788ad8d.tar.gz
gentoo-182efcb8fc6417291d26fd76e97ca8e8d788ad8d.tar.bz2
gentoo-182efcb8fc6417291d26fd76e97ca8e8d788ad8d.zip
gnome-extra/gnome-commander: Version bump to 1.6.3, new unique USE flag
Closes: https://github.com/gentoo/gentoo/pull/4430
Diffstat (limited to 'gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild')
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild
new file mode 100644
index 000000000000..f23f4af3ddda
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.6.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib samba test +unique"
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-libs/glib-2.44.0:2
+ unique? ( >=dev-libs/libunique-0.9.3:1 )
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( >=dev-util/cppunit-1.13.2 )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with pdf poppler) \
+ $(use_with samba) \
+ $(use_with taglib) \
+ $(use_with unique)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}