summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUwe Scholz <uwescholz@src.gnome.org>2019-05-01 21:58:16 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 18:24:20 +0200
commit44d177c87746fff8873d14a5b432adb59e2c74c3 (patch)
treeaabb5d6fd7283d3ce90718894f25b201fabc5f6e /gnome-extra/gnome-commander
parentapp-office/libreoffice-bin-debug: Version bump (diff)
downloadgentoo-44d177c87746fff8873d14a5b432adb59e2c74c3.tar.gz
gentoo-44d177c87746fff8873d14a5b432adb59e2c74c3.tar.bz2
gentoo-44d177c87746fff8873d14a5b432adb59e2c74c3.zip
gnome-extra/gnome-commander: check for gcc version correctly
Signed-off-by: Uwe Scholz <uwescholz@src.gnome.org> Closes: https://github.com/gentoo/gentoo/pull/11873 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-commander')
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.10.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.10.0.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.10.0.ebuild
index a5e742b15f16..87303c532e84 100644
--- a/gnome-extra/gnome-commander/gnome-commander-1.10.0.ebuild
+++ b/gnome-extra/gnome-commander/gnome-commander-1.10.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit gnome2 toolchain-funcs
DESCRIPTION="A graphical, full featured, twin-panel file manager"
HOMEPAGE="https://gcmd.github.io/"
@@ -35,7 +35,6 @@ DEPEND="
${RDEPEND}
dev-util/gtk-doc-am
sys-devel/gettext
- >=sys-devel/gcc-8.2.0
virtual/pkgconfig
test? ( >=dev-cpp/gtest-1.7.0 )
"
@@ -52,6 +51,13 @@ src_configure() {
$(use_with unique)
}
+pkg_pretend() {
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 8 ]]; then
+ eerror "Compilation with gcc older than version 8 is not supported"
+ die "GCC to old, please use gcc-8 or above"
+ fi
+}
+
pkg_postinst() {
gnome2_pkg_postinst
has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."