summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-commander
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-commander')
-rw-r--r--gnome-extra/gnome-commander/Manifest3
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.2.ebuild56
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.6.ebuild56
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild61
-rw-r--r--gnome-extra/gnome-commander/metadata.xml26
5 files changed, 202 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
new file mode 100644
index 000000000000..171df884c723
--- /dev/null
+++ b/gnome-extra/gnome-commander/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-commander-1.4.2.tar.xz 6285452 SHA256 8f47ac8428086406536c45b53cbf23b734322f2a557d91698cdeb2bd296f3029 SHA512 ad4b9b203f7f0040338f869fa4549a8d75494617d4117eab3449810467447c03c7e3d3f8ef09e755565f0f1266ead0981f8523619087284a891e61d0b6301d9b WHIRLPOOL a12f8cb94da1b8c5702e29c4f0f30df33181522c96ea68b1bf9d1c536238cff6ef968734b2c1a3df745d90b734c7e86e7cf13f6c306978a130b80920780a5960
+DIST gnome-commander-1.4.6.tar.xz 6350560 SHA256 55f3dd2ee4295c4b88a5c7810bbbd1db126213871b263dd5a44c0d48e8ef3a01 SHA512 e678234ffa12c4c44213c2a512a993008656e9a918f66d2731ab6f462f4c0345b6b71db72cae90b01309e5f422561cc6a09f631c90d906f49dc39b4f8c8f8ad2 WHIRLPOOL 5d2373a668ca2575726dce2d60134927b970e61e9da6b6c71b07f44dee623d73332eea69ebf95340fed3d324595257f544190db78da9b6d6716ece3ac9cb180e
+DIST gnome-commander-1.4.7.tar.xz 6368468 SHA256 54ac33b7df1268a8b1acf18d0b9dda35fa7438e15e2ace0f062e42525528a517 SHA512 3d7a5b00ffa5dd4666322312165670c8a04c6819234d3b3e5e44df2f3fb300ccac1ee8c4fb3961e963786eef543d8a77fcad3454b043dd5943f54d36dadf4403 WHIRLPOOL c6d73d58927bb9f6e224dff107b54047b95609060408b36992b4890318ebcb45a042f5117a3ed121d7fc5b563bbf402237e0a6bf94f684825d7ff0598a4eab23
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.2.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.2.ebuild
new file mode 100644
index 000000000000..5b2fe06d50df
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A full featured, twin-panel file manager for Gnome2"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="chm doc exif gsf pdf python taglib"
+
+RDEPEND="app-text/gnome-doc-utils
+ >=dev-libs/glib-2.6.0:2
+ >=dev-libs/libunique-0.9.3:1
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ doc? ( app-text/scrollkeeper )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_configure() {
+ G2CONF="$(use_enable doc scrollkeeper)
+ $(use_enable python)
+ $(use_with chm libchm)
+ $(use_with exif exiv2)
+ $(use_with gsf libgsf)
+ $(use_with taglib)
+ $(use_with pdf poppler)"
+ gnome2_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.6.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.6.ebuild
new file mode 100644
index 000000000000..461187e76b5c
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm doc exif gsf pdf python taglib"
+
+RDEPEND="app-text/gnome-doc-utils
+ >=dev-libs/glib-2.6.0:2
+ >=dev-libs/libunique-0.9.3:1
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ doc? ( app-text/scrollkeeper )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_configure() {
+ G2CONF="$(use_enable doc scrollkeeper)
+ $(use_enable python)
+ $(use_with chm libchm)
+ $(use_with exif exiv2)
+ $(use_with gsf libgsf)
+ $(use_with taglib)
+ $(use_with pdf poppler)"
+ gnome2_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild
new file mode 100644
index 000000000000..4b9ca82e121e
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib"
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-libs/glib-2.6.0:2
+ >=dev-libs/libunique-0.9.3:1
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with taglib) \
+ $(use_with pdf poppler)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}
diff --git a/gnome-extra/gnome-commander/metadata.xml b/gnome-extra/gnome-commander/metadata.xml
new file mode 100644
index 000000000000..53b83744b9fe
--- /dev/null
+++ b/gnome-extra/gnome-commander/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>u.scholz83@gmx.de</email>
+ <name>Uwe Scholz</name>
+ <description>Proxy maintainer. Assign bugs to him.</description>
+ </maintainer>
+<upstream>
+ <maintainer status="active">
+ <email>u.scholz83@gmx.de</email>
+ <name>Uwe Scholz</name>
+ </maintainer>
+ <changelog>https://git.gnome.org/browse/gnome-commander/tree/NEWS?h=gcmd-1-4</changelog>
+ <bugs-to>https://bugzilla.gnome.org/browse.cgi?product=gnome-commander</bugs-to>
+ <remote-id type="freecode">gnome-commander</remote-id>
+</upstream>
+<use>
+ <flag name="chm">Enable metadata support for Microsoft Compiled HTML Help files</flag>
+ <flag name="gsf">Add metadata support for OLE, OLE2 and ODF</flag>
+ <flag name="pdf">Add metadata support for PDF</flag>
+ <flag name="python">Add support for python plugins"</flag>
+ <flag name="taglib">Add metadata support for ID3, Vorbis, FLAC and APE</flag>
+</use>
+</pkgmetadata>