summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-do-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-do-plugins')
-rw-r--r--gnome-extra/gnome-do-plugins/Manifest1
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild53
-rw-r--r--gnome-extra/gnome-do-plugins/metadata.xml13
3 files changed, 67 insertions, 0 deletions
diff --git a/gnome-extra/gnome-do-plugins/Manifest b/gnome-extra/gnome-do-plugins/Manifest
new file mode 100644
index 000000000000..4eb0613a4304
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/Manifest
@@ -0,0 +1 @@
+DIST gnome-do-plugins-0.8.5.tar.gz 3176035 SHA256 c4b544bd08a31e86b83311c49db85d8fdf3130803dfd37acd0c89e7843548f3c SHA512 55b1287fb1cca7cea8b681ebce470ee405594b64d6bf60b0f2dac60cc4267ac28c22fd8bdd8ffa9893abba7e93844eed498799cbe6594098bdca3d38923ea890 WHIRLPOOL dfa3810332f495f96085beef6c8893f4975da21050ed41d231ead43d3b4833d8973be112809bd08a0bda79c578e45e52cb3a414e689c6e9b304f62a15f458b6f
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild
new file mode 100644
index 000000000000..e25e772eed99
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 mono-env versionator
+
+MY_PN="do-plugins"
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins to put the Do in Gnome Do"
+HOMEPAGE="https://launchpad.net/do-plugins"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="banshee"
+
+RDEPEND="
+ >=gnome-extra/gnome-do-0.9
+ dev-dotnet/wnck-sharp
+ banshee? ( >=media-sound/banshee-1.4.2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Skip failing plugins (from ArchLinux)
+ sed -i -e '/DiskMounter/d
+ /Transmission/d' Makefile.am || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use banshee) \
+ --disable-empathy \
+ --disable-flickr \
+ --disable-transmission
+}
+
+src_compile() {
+ # The make system is unfortunately broken for parallel builds and
+ # upstream indicated on IRC that they have no intention to fix
+ # that.
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+}
diff --git a/gnome-extra/gnome-do-plugins/metadata.xml b/gnome-extra/gnome-do-plugins/metadata.xml
new file mode 100644
index 000000000000..767c8263a78d
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="banshee">Enables the Banshee (<pkg>media-sound/banshee</pkg>) plugin</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">do-plugins</remote-id>
+ </upstream>
+</pkgmetadata>