summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-do
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-do')
-rw-r--r--gnome-extra/gnome-do/Manifest1
-rw-r--r--gnome-extra/gnome-do/files/gnome-do-0.8.3.1-gtk-2.22.patch17
-rw-r--r--gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch70
-rw-r--r--gnome-extra/gnome-do/files/gnome-do-0.8.4-mono-2.8.patch48
-rw-r--r--gnome-extra/gnome-do/files/gnome-do-0.8.5-glib-2.32.patch16
-rw-r--r--gnome-extra/gnome-do/gnome-do-0.9.ebuild44
-rw-r--r--gnome-extra/gnome-do/metadata.xml19
7 files changed, 215 insertions, 0 deletions
diff --git a/gnome-extra/gnome-do/Manifest b/gnome-extra/gnome-do/Manifest
new file mode 100644
index 000000000000..0c146fad184a
--- /dev/null
+++ b/gnome-extra/gnome-do/Manifest
@@ -0,0 +1 @@
+DIST gnome-do-0.9.tar.gz 881467 SHA256 554b6f7f2b6e8c5fcdaeb41e17e460ac0b7f26bde7d42182cbec08b3abfd5317 SHA512 7fba3291c0320e92ab3c4a696c3e99bcf8a6171dae592a492a55dddfbf73355f749ebbf720f0a3d0e667b949cc74b8dcbba46af57e103dc3d0d3e5aa120296f9 WHIRLPOOL 2e7f6181a4aeff90553f349a237108280acd43e4ff0a971c61db14c9ad79e62258fadd3812c9085e9ac0b95f3527f483be19a5d9e14504d634caeb2ef9507296
diff --git a/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-gtk-2.22.patch b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-gtk-2.22.patch
new file mode 100644
index 000000000000..02d973aa1e3a
--- /dev/null
+++ b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-gtk-2.22.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/show_bug.cgi?id=346123
+
+Removes depracted use of gdk_display.
+
+=== modified file 'libdo/keybinder.c'
+--- libdo/keybinder.c 2009-07-23 07:17:00 +0000
++++ libdo/keybinder.c 2010-11-09 10:45:25 +0000
+@@ -319,7 +319,7 @@
+ XModifierKeymap *mod_keymap;
+ gboolean retval = FALSE;
+
+- mod_keymap = XGetModifierMapping (gdk_display);
++ mod_keymap = XGetModifierMapping (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()));
+
+ map_size = 8 * mod_keymap->max_keypermod;
+
+
diff --git a/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch
new file mode 100644
index 000000000000..2e492a87edde
--- /dev/null
+++ b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch
@@ -0,0 +1,70 @@
+https://bugs.launchpad.net/do/+bug/634556
+https://bugs.launchpad.net/do/+bug/634550
+
+Patches by Andrew Jorgensen
+
+--- Do.Interface.Linux.Docky/src/Docky.Interface/TextRenderContext.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do.Interface.Linux.Docky/src/Docky.Interface/TextRenderContext.cs 2010-09-01 13:11:53.000000000 -0600
+@@ -45,12 +45,12 @@
+
+ public TextRenderContext (Cairo.Context cr, string text, int width)
+ {
+- Context = cr;
+- Text = text;
+- Alignment = Alignment.Left;
+- MaximumWidth = width;
+- WrapMode = WrapMode.WordChar;
+- EllipsizeMode = EllipsizeMode.End;
++ this.Context = cr;
++ this.Text = text;
++ this.Alignment = Alignment.Left;
++ this.MaximumWidth = width;
++ this.WrapMode = WrapMode.WordChar;
++ this.EllipsizeMode = EllipsizeMode.End;
+ }
+ }
+ }
+--- Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2010-09-01 13:58:26.000000000 -0600
+@@ -57,7 +57,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ColorConfigurationWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ColorConfigurationWidget";
++ base.Name = "Do.UI.ColorConfigurationWidget";
+ // Container child Do.UI.ColorConfigurationWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2010-09-01 13:58:43.000000000 -0600
+@@ -33,7 +33,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.GeneralPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.GeneralPreferencesWidget";
++ base.Name = "Do.UI.GeneralPreferencesWidget";
+ // Container child Do.UI.GeneralPreferencesWidget.Gtk.Container+ContainerChild
+ this.alignment4 = new Gtk.Alignment(0.5F, 0.5F, 1F, 1F);
+ this.alignment4.Name = "alignment4";
+--- Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2010-09-01 13:59:08.000000000 -0600
+@@ -27,7 +27,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.KeybindingsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.KeybindingsPreferencesWidget";
++ base.Name = "Do.UI.KeybindingsPreferencesWidget";
+ // Container child Do.UI.KeybindingsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2010-09-01 13:59:19.000000000 -0600
+@@ -43,7 +43,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ManagePluginsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ManagePluginsPreferencesWidget";
++ base.Name = "Do.UI.ManagePluginsPreferencesWidget";
+ // Container child Do.UI.ManagePluginsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox3 = new Gtk.VBox();
+ this.vbox3.Name = "vbox3";
diff --git a/gnome-extra/gnome-do/files/gnome-do-0.8.4-mono-2.8.patch b/gnome-extra/gnome-do/files/gnome-do-0.8.4-mono-2.8.patch
new file mode 100644
index 000000000000..4054ae99ba18
--- /dev/null
+++ b/gnome-extra/gnome-do/files/gnome-do-0.8.4-mono-2.8.patch
@@ -0,0 +1,48 @@
+https://bugs.launchpad.net/do/+bug/634550
+
+Patches by Andrew Jorgensen
+
+--- Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2010-09-01 13:58:26.000000000 -0600
+@@ -57,7 +57,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ColorConfigurationWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ColorConfigurationWidget";
++ base.Name = "Do.UI.ColorConfigurationWidget";
+ // Container child Do.UI.ColorConfigurationWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2010-09-01 13:58:43.000000000 -0600
+@@ -33,7 +33,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.GeneralPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.GeneralPreferencesWidget";
++ base.Name = "Do.UI.GeneralPreferencesWidget";
+ // Container child Do.UI.GeneralPreferencesWidget.Gtk.Container+ContainerChild
+ this.alignment4 = new Gtk.Alignment(0.5F, 0.5F, 1F, 1F);
+ this.alignment4.Name = "alignment4";
+--- Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2010-09-01 13:59:08.000000000 -0600
+@@ -27,7 +27,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.KeybindingsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.KeybindingsPreferencesWidget";
++ base.Name = "Do.UI.KeybindingsPreferencesWidget";
+ // Container child Do.UI.KeybindingsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2010-09-01 13:59:19.000000000 -0600
+@@ -43,7 +43,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ManagePluginsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ManagePluginsPreferencesWidget";
++ base.Name = "Do.UI.ManagePluginsPreferencesWidget";
+ // Container child Do.UI.ManagePluginsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox3 = new Gtk.VBox();
+ this.vbox3.Name = "vbox3";
diff --git a/gnome-extra/gnome-do/files/gnome-do-0.8.5-glib-2.32.patch b/gnome-extra/gnome-do/files/gnome-do-0.8.5-glib-2.32.patch
new file mode 100644
index 000000000000..88fc0c443e36
--- /dev/null
+++ b/gnome-extra/gnome-do/files/gnome-do-0.8.5-glib-2.32.patch
@@ -0,0 +1,16 @@
+ libdo/keybinder.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/libdo/keybinder.h b/libdo/keybinder.h
+index 2a39958..da202e6 100644
+--- a/libdo/keybinder.h
++++ b/libdo/keybinder.h
+@@ -24,7 +24,7 @@
+ #ifndef __DO_KEY_BINDER_H__
+ #define __DO_KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/gnome-extra/gnome-do/gnome-do-0.9.ebuild b/gnome-extra/gnome-do/gnome-do-0.9.ebuild
new file mode 100644
index 000000000000..56b1c22d706d
--- /dev/null
+++ b/gnome-extra/gnome-do/gnome-do-0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit gnome2 mono-env
+
+DESCRIPTION="GNOME Do allows you to get things done quickly"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/do/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="<dev-lang/mono-3
+ >=dev-dotnet/gconf-sharp-2.24.0
+ >=dev-dotnet/gtk-sharp-2.12.6
+ >=dev-dotnet/glade-sharp-2.12.6
+ dev-dotnet/ndesk-dbus
+ dev-dotnet/ndesk-dbus-glib
+ >=dev-dotnet/gnome-desktop-sharp-2.26.0
+ >=dev-dotnet/gnome-keyring-sharp-1.0.0
+ >=dev-dotnet/gnome-sharp-2.24.0
+ >=dev-dotnet/gnomevfs-sharp-2.24.0
+ >=dev-dotnet/wnck-sharp-2.24.0
+ >=dev-dotnet/art-sharp-2.24.0
+ >=dev-dotnet/rsvg-sharp-2.24.0
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/notify-sharp
+ !<gnome-extra/gnome-do-plugins-0.8.4"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig"
+
+#src_prepare() {
+# sed -e 's: -Werror : :' \
+# -i configure.ac || die
+# eautoreconf
+#
+# gnome2_src_prepare
+#}
diff --git a/gnome-extra/gnome-do/metadata.xml b/gnome-extra/gnome-do/metadata.xml
new file mode 100644
index 000000000000..49a068109484
--- /dev/null
+++ b/gnome-extra/gnome-do/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>giuse88@gmail.com</email>
+ <name>Giuseppe Pes</name>
+ </maintainer>
+ <longdescription>
+ GNOME Do allows you to quickly search for many items present in your GNOME
+ desktop environment (applications, Evolution contacts, Firefox bookmarks,
+ files, artists and albums in Rhythmbox, Pidgin buddies, etc.) and perform
+ commonly used actions on those items (Run, Open, Email, Chat, Play, etc.).
+ GNOME Do is inspired by Quicksilver and GNOME Launch Box.
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">do</remote-id>
+ </upstream>
+</pkgmetadata>