summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-03-13 18:31:42 +0100
committerPacho Ramos <pacho@gentoo.org>2022-03-13 19:36:34 +0100
commit71b168fc71138cb18b694900e7745add5e3cb67e (patch)
treea7a81056b422e6b4b6dc43dfc26a01f3b2f006b0 /gnome-extra/gnome-shell-extension-alphabetical-grid
parentapp-editors/emacs: New pretest version 28.0.92 (diff)
downloadgentoo-71b168fc71138cb18b694900e7745add5e3cb67e.tar.gz
gentoo-71b168fc71138cb18b694900e7745add5e3cb67e.tar.bz2
gentoo-71b168fc71138cb18b694900e7745add5e3cb67e.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: Bump to 20.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-alphabetical-grid')
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-20.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index ea7b57392544..a0f59e660940 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-alphabetical-grid-19.0.tar.gz 288661 BLAKE2B b3df5594422f7d5ba249ec5a3eebf178e845fc2f36f838f61c86c0aa1918f9ca7e942a6af358e3f1744ce7f25a507f3e97bac71848cf6c0bac6339139ffd0d3d SHA512 139f1d06ebeef3b76ac84f71190cf77ebc77571ff3b489bb86f578cfa01ce7de47e53798fece93cb6c45bd82cb6b2a425ba255c1485d5b8739da28bd9959fce8
+DIST gnome-shell-extension-alphabetical-grid-20.0.tar.gz 288708 BLAKE2B 7a03ccc523f950d7df5ac3b2a75894094963db63df72813f3dae0780e4b49eb51958d8069128df76a38a49fc624114bd7ef901db214d0b612278e33d636151e3 SHA512 681ce3be3700db94ba9095c573b3c322d2c7d1ab875bec1f67a821872121318df8c4568281345cf9985c0ed87656e08fc59a48e3a253e63696304d29f5c8a4b6
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-20.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-20.0.ebuild
new file mode 100644
index 000000000000..2164b03efc89
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-20.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE.txt Makefile schemas || die
+ mv -v ui/* . || die # Searches for these files in parent dir
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}