summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-04-20 19:56:37 +0200
committerPacho Ramos <pacho@gentoo.org>2019-04-20 19:59:47 +0200
commit13f10c832594e77ced961cbe2001a6c6dbb285bd (patch)
tree38d1c0961de58ee49fc7364e5824a5688d8d8429 /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentfeatures/selinux/package.mask: mask for gnome-shell-extension (diff)
downloadgentoo-13f10c832594e77ced961cbe2001a6c6dbb285bd.tar.gz
gentoo-13f10c832594e77ced961cbe2001a6c6dbb285bd.tar.bz2
gentoo-13f10c832594e77ced961cbe2001a6c6dbb285bd.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Add extension to show full app name and tooltip
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch24
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch45
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild46
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml7
5 files changed, 123 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
new file mode 100644
index 000000000000..f9ca3a2e56fe
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -0,0 +1 @@
+DIST gnome-shell-extension-applications-overview-tooltip-4.tar.gz 79384 BLAKE2B 9e428b66351cb26615050a1c2e8e7ee1e325079b46ae7fc40eb836aef652ca33e04af9b39c07098364b6844c057867e9e5ddee291748afe63084caa108289037 SHA512 befb6f11f7836010077aba10d8664ba462c7153b498e25b5ad0fa12e065dc0b84302b7cc97d1f0685108ea92c20b61491c85a25a4511ad7237b1c0122a587868
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch
new file mode 100644
index 000000000000..0ed36b288f0e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-js-warning.patch
@@ -0,0 +1,24 @@
+From 27af671cca3fc6b9dd5c8687c1b3d0d530ccc516 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rapha=C3=ABl=20Rochet?= <raphael@rri.fr>
+Date: Sun, 23 Sep 2018 16:39:36 +0200
+Subject: [PATCH] Fix JS warning
+
+---
+ extension.js | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 346a89a..1eda926 100644
+--- a/extension.js
++++ b/extension.js
+@@ -250,8 +250,8 @@ function _showTooltip(actor) {
+
+ if (!detailtext) { _ttdetail.hide() } else { _ttdetail.show() };
+
+- [stageX, stageY] = actor.get_transformed_position();
+- [iconWidth, iconHeight] = actor.get_transformed_size();
++ let [stageX, stageY] = actor.get_transformed_position();
++ let [iconWidth, iconHeight] = actor.get_transformed_size();
+ let y = stageY + iconHeight + 5;
+ let x = stageX - Math.round((_ttbox.get_width() - iconWidth)/2);
+
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch
new file mode 100644
index 000000000000..333d1c7c22b3
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/files/gnome-shell-extension-applications-overview-tooltip-4-old-animation.patch
@@ -0,0 +1,45 @@
+From ff442818fb5c4fd9521c532200ff825061fa35e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rapha=C3=ABl=20Rochet?= <raphael@rri.fr>
+Date: Mon, 11 Feb 2019 21:26:24 +0100
+Subject: [PATCH] Fix #6 by removing old swipe animation
+
+---
+ extension.js | 16 ++--------------
+ 1 file changed, 2 insertions(+), 14 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 1eda926..deffc58 100644
+--- a/extension.js
++++ b/extension.js
+@@ -175,16 +175,10 @@ function _onLeave() {
+ _labelTimeoutId = 0;
+ }
+
+- // but give a chance to skip hover delay if the cursor hovers another icon
+ if (_labelShowing) {
+- _resetHoverTimeoutId = Mainloop.timeout_add(HIDEDELAY, function() {
+- _hideTooltip();
+- _labelShowing = false;
+- _resetHoverTimeoutId = 0;
+- return false;
+- } );
++ _hideTooltip();
++ _labelShowing = false;
+ }
+-
+ }
+
+
+@@ -277,12 +271,6 @@ function _showTooltip(actor) {
+
+ }
+
+- // do not hide tooltip while cursor is on icon
+- if (_resetHoverTimeoutId > 0) {
+- Mainloop.source_remove(_resetHoverTimeoutId);
+- _resetHoverTimeoutId = 0;
+- }
+-
+ } else {
+
+ // No tooltip to show : act like we're leaving an icon
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild
new file mode 100644
index 000000000000..a86a660de2e8
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.20
+"
+DEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ # From 'master'
+ "${FILESDIR}"/${P}-old-animation.patch
+ "${FILESDIR}"/${P}-js-warning.patch
+)
+
+src_install() {
+ einstalldocs
+ rm -f README.md || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+ glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet/schemas || die
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>