summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-05-20 14:00:34 +0200
committerPacho Ramos <pacho@gentoo.org>2021-05-20 14:36:54 +0200
commite57081975a05f237a614b3df6e9a62af18167137 (patch)
tree6284ac47be745dad71fc2f167b630cef37fc5e6a /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentgnome-extra/gnome-shell-extension-applications-overview-tooltip: Drop old (diff)
downloadgentoo-e57081975a05f237a614b3df6e9a62af18167137.tar.gz
gentoo-e57081975a05f237a614b3df6e9a62af18167137.tar.bz2
gentoo-e57081975a05f237a614b3df6e9a62af18167137.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump to v12
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index dee701e3de05..16ab7c3c1940 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-applications-overview-tooltip-11.tar.gz 81717 BLAKE2B bbafaa58bd9b7b56c5cc12c953922d40c1901fe78491d5ea344ab6f3dda65e51c02851b2106ef271d662be365722ca35f61a836f509bc1e6a4e6c03ecf1de3eb SHA512 c108b8bbf09793a18eced02e7fc5a68f1d71b9b31f0480b9346bf9b44507fedf85e6c1e640fa7d282ea69b63ad056116acecb494beb5c18b784b00348e485f00
+DIST gnome-shell-extension-applications-overview-tooltip-12.tar.gz 27394 BLAKE2B 169460c7063fda0f664688303984c4a5c7fcd8a6b32281c2eb630ebea8143b95e96038f130b09c939371474b5ef27656cf77eec942412fcf3908a5d9fb8ae202 SHA512 4c993256d1f6d7d3a2c72c88f6f88facf7ff8237d489950484f54a68f09741e526f0e0a7c2862251fc2579fd3cdd496c9136bb222374abfacbace1615e263239
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild
new file mode 100644
index 000000000000..6189ad2b2b21
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+extension_uuid="applications-overview-tooltip@RaphaelRochet"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}