summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-09 22:12:04 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-09 22:50:57 +0100
commit5f84b240b349f06bf3c10416bc9ea58d6fdcf5fa (patch)
treee7bceb24a8127090e95c466cc679490af32ba3c6 /gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild
parentsci-geosciences/gnome-maps: Drop old (diff)
downloadgentoo-5f84b240b349f06bf3c10416bc9ea58d6fdcf5fa.tar.gz
gentoo-5f84b240b349f06bf3c10416bc9ea58d6fdcf5fa.tar.bz2
gentoo-5f84b240b349f06bf3c10416bc9ea58d6fdcf5fa.zip
gnome-extra/gnome-system-monitor: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild')
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild
new file mode 100644
index 000000000000..dd1c892fc82d
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.18.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2=
+ >=x11-libs/gtk+-3.12:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+ systemd? ( >=sys-apps/systemd-44:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck)
+}