summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-09-29 18:15:42 +0200
committerPacho Ramos <pacho@gentoo.org>2019-09-29 18:15:58 +0200
commit637b1550f7a03d6f0026f0f7935c3b51acbf46e0 (patch)
treee9e058f36a2b20baf8f2ff85b889ac57b34e250d /gnome-extra/gnome-tweaks
parentacct-user/alias: add dependency for qmail group (diff)
downloadgentoo-637b1550f7a03d6f0026f0f7935c3b51acbf46e0.tar.gz
gentoo-637b1550f7a03d6f0026f0f7935c3b51acbf46e0.tar.bz2
gentoo-637b1550f7a03d6f0026f0f7935c3b51acbf46e0.zip
gnome-extra/gnome-tweaks: Bump to 3.32.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-tweaks')
-rw-r--r--gnome-extra/gnome-tweaks/Manifest1
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-3.32.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweaks/Manifest b/gnome-extra/gnome-tweaks/Manifest
index 5ff4a3f6c66b..f393b81dc861 100644
--- a/gnome-extra/gnome-tweaks/Manifest
+++ b/gnome-extra/gnome-tweaks/Manifest
@@ -1 +1,2 @@
DIST gnome-tweaks-3.30.2.tar.xz 281820 BLAKE2B cd980f77a05d74f556fe461f1dc35122efb23ab0885b84ddb71c873dd6cb424d4ae213d393b7555f8baed8eb5fb3df8afa7d9b4cb92d772ba9eed59892871bfe SHA512 183df35e8051aa1fba54ca45aca64d665f28d92c56879ff6fa60adf3809a05676db15d97d7023bf5ffb9bac33df259eb62742bee3cebeb87d8ffa39679b2c078
+DIST gnome-tweaks-3.32.0.tar.xz 241492 BLAKE2B f3c0a25b39726600fc5d53d8d3c343dbcde594642a87fc56dd3fff9b88a3498e0f283568a944fc37445c138201db1f280222eb1161f5b8351c566537404cde5e SHA512 8107e9d2b33ac6c46e8d0076b27a1c3a84e1721e49a6b80da28fe854f6f4f6693bc7f7e836c54d39bafec79dcee8a6e2b2962580a77d7d01bfc06c6d11206d8f
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-3.32.0.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-3.32.0.ebuild
new file mode 100644
index 000000000000..d1198e1233ea
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-3.32.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit gnome.org meson python-single-r1 xdg
+
+DESCRIPTION="Customize advanced GNOME 3 options"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+"
+# See README.md for list of deps
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
+ >=gnome-base/gnome-settings-daemon-3
+ x11-themes/sound-theme-freedesktop
+
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=gnome-base/gnome-desktop-3.30:3[introspection]
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/libnotify[introspection]
+
+ >=gnome-base/gsettings-desktop-schemas-3.28
+ >=gnome-base/gnome-shell-3.24
+ x11-wm/mutter
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=">=sys-devel/gettext-0.19.8"
+
+PATCHES=(
+ "${FILESDIR}"/3.28.1-gentoo-cursor-themes.patch # Add contents of Gentoo's cursor theme directory to cursor theme list
+)
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/
+}