summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-29 16:56:47 +0300
committerMart Raudsepp <leio@gentoo.org>2020-03-29 19:18:13 +0300
commit9ce29e6be1338b0ca8edbff7835ff10b5ab01f0c (patch)
tree338d0601448dd0fad74f01d39db01e3a2af5fbe8 /gnome-extra/gnome-tweaks
parentgnome-extra/sushi: bump to 3.34.0 (diff)
downloadgentoo-9ce29e6be1338b0ca8edbff7835ff10b5ab01f0c.tar.gz
gentoo-9ce29e6be1338b0ca8edbff7835ff10b5ab01f0c.tar.bz2
gentoo-9ce29e6be1338b0ca8edbff7835ff10b5ab01f0c.zip
gnome-extra/gnome-tweaks: bump to 3.34.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-tweaks')
-rw-r--r--gnome-extra/gnome-tweaks/Manifest1
-rw-r--r--gnome-extra/gnome-tweaks/files/3.34.0-fix-python.patch85
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-3.34.0.ebuild51
3 files changed, 137 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweaks/Manifest b/gnome-extra/gnome-tweaks/Manifest
index 883637886a8e..9f0b2f95bc7c 100644
--- a/gnome-extra/gnome-tweaks/Manifest
+++ b/gnome-extra/gnome-tweaks/Manifest
@@ -1 +1,2 @@
DIST gnome-tweaks-3.32.0.tar.xz 241492 BLAKE2B f3c0a25b39726600fc5d53d8d3c343dbcde594642a87fc56dd3fff9b88a3498e0f283568a944fc37445c138201db1f280222eb1161f5b8351c566537404cde5e SHA512 8107e9d2b33ac6c46e8d0076b27a1c3a84e1721e49a6b80da28fe854f6f4f6693bc7f7e836c54d39bafec79dcee8a6e2b2962580a77d7d01bfc06c6d11206d8f
+DIST gnome-tweaks-3.34.0.tar.xz 246592 BLAKE2B 8701b03f64bf6b779f6f96de25684602447b4da8f2714cb38f866e5016532aad3283f3dc217b29161534958c03e72aed33c0803e60681a3616818d037c23e5e8 SHA512 1d2b21a31550d4b48afd02a9fcfb9844eacac7aa726ef624abcb40225af31da29b34e9032b3bb2943e5cb5f7553a6f931467d04bfbc2b026732e6bdcb86eb840
diff --git a/gnome-extra/gnome-tweaks/files/3.34.0-fix-python.patch b/gnome-extra/gnome-tweaks/files/3.34.0-fix-python.patch
new file mode 100644
index 000000000000..2501bc7c4d12
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/files/3.34.0-fix-python.patch
@@ -0,0 +1,85 @@
+From 0ec042734f63a3a870920b1e71f07851d335ea45 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 29 Mar 2020 16:05:36 +0300
+Subject: [PATCH] build: Fix python files installation handling
+
+The deprecated meson python3 module tends to end up installing only
+to a python version that meson is installed for too, possibly
+breaking some expectations downstream that want it installed to
+a specific python3 version, that might not match what the build
+machine uses for meson.
+Fix it by using the non-deprecated python module and methods from it.
+
+The python module exists since 0.46, which should be safe to require
+by now. There were meson 0.50 features used already, but unnecessarily,
+as the configure_file install parameter was added then, but all versions
+default to `true` anyhow. However in practice this only emitted a
+warning with newer meson versions and was able to build fine with older
+versions too. However fix it too, so that we are now warning-free for
+meson features after raising of the meson version dep.
+---
+ gtweak/meson.build | 5 ++---
+ meson.build | 12 ++++++++----
+ 2 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/gtweak/meson.build b/gtweak/meson.build
+index 3d9a743..4e558b4 100644
+--- a/gtweak/meson.build
++++ b/gtweak/meson.build
+@@ -11,7 +11,6 @@ configure_file(
+ input: 'defs.py.in',
+ output: 'defs.py',
+ configuration: defs_conf,
+- install: true,
+ install_dir: gtweakdir
+ )
+
+@@ -46,5 +45,5 @@ tweak_sources = [
+ 'tweaks/tweak_wacom.py',
+ ]
+
+-install_data(shell_sources, install_dir: gtweakdir)
+-install_data(tweak_sources, install_dir: gtweakdir + '/tweaks')
++python3.install_sources(shell_sources, subdir: 'gtweak')
++python3.install_sources(tweak_sources, subdir: join_paths('gtweak', 'tweaks'))
+diff --git a/meson.build b/meson.build
+index b7da518..df49ae3 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,11 +1,16 @@
+ project('gnome-tweaks',
+ version: '3.34.0',
+- meson_version: '>= 0.40.0'
++ meson_version: '>= 0.46.0'
+ )
+
+ gnome = import('gnome')
+ i18n = import('i18n')
+-python3 = import('python3')
++pymod = import('python')
++python3 = pymod.find_installation('python3')
++
++if not python3.found()
++ error('No valid python3 installation found')
++endif
+
+ prefix = get_option('prefix')
+
+@@ -13,13 +18,12 @@ bindir = join_paths(prefix, get_option('bindir'))
+ datadir = join_paths(prefix, get_option('datadir'))
+ libexecdir = join_paths(prefix, get_option('libexecdir'))
+ localedir = join_paths(prefix, get_option('localedir'))
+-pythondir = join_paths(prefix, python3.sysconfig_path('purelib'))
+
+ pkgdatadir = join_paths(datadir, meson.project_name())
+
+ appdatadir = join_paths(datadir, 'metainfo')
+ desktopdir = join_paths(datadir, 'applications')
+-gtweakdir = join_paths(pythondir, 'gtweak')
++gtweakdir = python3.get_install_dir(subdir: 'gtweak')
+ icondir = join_paths(datadir, 'icons', 'hicolor')
+ schemadir = join_paths(datadir, 'glib-2.0', 'schemas')
+
+--
+2.20.1
+
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-3.34.0.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-3.34.0.ebuild
new file mode 100644
index 000000000000..7a5ad14a25b8
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-3.34.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org meson python-single-r1 xdg
+
+DESCRIPTION="Customize advanced GNOME 3 options"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+# See README.md for list of deps
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=gnome-base/gnome-settings-daemon-3
+ x11-themes/sound-theme-freedesktop
+
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=gnome-base/gnome-desktop-3.30:3[introspection]
+ gui-libs/libhandy:0.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/libnotify[introspection]
+
+ >=gnome-base/gsettings-desktop-schemas-3.33.0
+ >=gnome-base/gnome-shell-3.24
+ x11-wm/mutter
+"
+BDEPEND=">=sys-devel/gettext-0.19.8"
+
+PATCHES=(
+ "${FILESDIR}"/3.28.1-gentoo-cursor-themes.patch # Add contents of Gentoo's cursor theme directory to cursor theme list
+ "${FILESDIR}"/${PV}-fix-python.patch
+)
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}