summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-01-29 21:16:16 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-01-29 21:18:21 +0100
commit6db1cfeb695624be1aea007bc691c7252f74a95b (patch)
treea7458a05fdf49ad1ca6884beb709ef53f32dbf75 /gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild
parentmedia-libs/taglib: stable 1.11.1_p20181028 for sparc, bug #676614 (diff)
downloadgentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.tar.gz
gentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.tar.bz2
gentoo-6db1cfeb695624be1aea007bc691c7252f74a95b.zip
gnome-extra/gtkhtml: added revision with enchant-2 compatibility
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild')
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild b/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild
new file mode 100644
index 000000000000..50c276735279
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-4.10.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools gnome2
+
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
+HOMEPAGE="https://git.gnome.org/browse/gtkhtml"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+# orbit is referenced in configure, but is not used anywhere else
+RDEPEND="
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/cairo-1.10:=
+ x11-libs/pango
+ >=app-text/enchant-2.0.0
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ sys-devel/gettext
+ dev-util/glib-utils
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/enchant-2.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't collide with 3.14 slot
+ mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
+}