summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-15 11:03:21 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-15 11:30:10 +0100
commit30a11ad2f14354f47b50c64e2f529e31fad66e52 (patch)
tree28b14d1340ffe67f8871e80c0559866981d21826 /gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild
parentgnome-extra/gnome-weather: Drop old (diff)
downloadgentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.tar.gz
gentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.tar.bz2
gentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.zip
gnome-extra/gtkhtml: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild')
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild b/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild
new file mode 100644
index 000000000000..f5939c663b55
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
+HOMEPAGE="https://git.gnome.org/browse/gtkhtml"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# orbit is referenced in configure, but is not used anywhere else
+RDEPEND="
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/cairo-1.10:=
+ x11-libs/pango
+ >=app-text/enchant-1.1.7:=
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't collide with 3.14 slot
+ mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
+}