summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-23 14:40:03 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-23 16:15:07 +0300
commit2028e42621eaa96f4a651cce89b6f1ad7b149b0c (patch)
tree48b475304c785e527e7e71b08ea13d45b398ca04 /gnome-extra/libgsf
parentsys-boot/refind: bump to 0.11.2 (diff)
downloadgentoo-2028e42621eaa96f4a651cce89b6f1ad7b149b0c.tar.gz
gentoo-2028e42621eaa96f4a651cce89b6f1ad7b149b0c.tar.bz2
gentoo-2028e42621eaa96f4a651cce89b6f1ad7b149b0c.zip
gnome-extra/libgsf: bump to 1.14.43
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.43.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index f97303dd56b0..474262a522cd 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.41.tar.xz 616944 BLAKE2B 300da197dcbd5568758da21ea25b25636fcd7b16483a5b526e1c9e0242145208580f6edd41ac1028b7b51fe159eab506a32947ef81beb47883cf133bf2ea9cb7 SHA512 e3892500288e5d1d9e46cdd3940d872ae2504fe54babe2dc085218c3e1a5aff5a7220c88bde730239af4a56c340a22f47337280b8892f0ab31e1e751adea9bc3
+DIST libgsf-1.14.43.tar.xz 618272 BLAKE2B a381125ce75d06ae4bf1c9dbe9b2e207534ff7c3310e40984e482bc5120eae45a7e3ed4cfd878890037f31ee540c700dea3120119b9a533fa79cab317a0c83a8 SHA512 bb487de9358c057fc73f3414c9515726315be9b6d78456253daaca1cbd58281de8766e0b72914532d63fab04d3ae2cf90f711f436c7b4f70620d77e8a7802ac9
diff --git a/gnome-extra/libgsf/libgsf-1.14.43.ebuild b/gnome-extra/libgsf/libgsf-1.14.43.ebuild
new file mode 100644
index 000000000000..77a9583b2c3f
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.43.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}