summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-04 17:59:22 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-04 17:59:37 -0400
commitd39306de6e242041a8cf16cbb5e49aef81aacae0 (patch)
tree4cb223aee0f7a3b58aace1318ba4e3ef04d21bf3 /gnome-extra/nm-applet/nm-applet-1.2.4.ebuild
parentdev-perl/MIME-tools: Remove POD Authortests (diff)
downloadgentoo-d39306de6e242041a8cf16cbb5e49aef81aacae0.tar.gz
gentoo-d39306de6e242041a8cf16cbb5e49aef81aacae0.tar.bz2
gentoo-d39306de6e242041a8cf16cbb5e49aef81aacae0.zip
gnome-extra/nm-applet: bump to 1.2.4
Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-1.2.4.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.2.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-1.2.4.ebuild b/gnome-extra/nm-applet/nm-applet-1.2.4.ebuild
new file mode 100644
index 000000000000..5899e4b9e577
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome2
+
+DESCRIPTION="GNOME applet for NetworkManager"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/dbus-glib-0.88
+ >=sys-apps/dbus-1.4.1
+ >=sys-auth/polkit-0.96-r1
+ >=x11-libs/gtk+-3.4:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ app-text/iso-codes
+ >=net-misc/networkmanager-1.2:=[introspection?]
+ net-misc/mobile-broadband-provider-info
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ virtual/freedesktop-icon-theme
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.50.1
+"
+
+PDEPEND="virtual/notification-daemon" #546134
+
+src_configure() {
+ gnome2_src_configure \
+ --without-appindicator \
+ --disable-more-warnings \
+ --disable-static \
+ --localstatedir=/var \
+ $(use_enable introspection)
+}