summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-02 13:21:28 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-02 14:36:30 +0200
commit2c94b2e8aadee9bcff10389bb93403161365e2e0 (patch)
tree87117fd6042880b5fc2508e9ac9867acae47f36f /gnome-extra/nm-applet/nm-applet-1.4.2.ebuild
parentnet-fs/samba: Use zeroconf instead of avahi USE flag (#477620) (diff)
downloadgentoo-2c94b2e8aadee9bcff10389bb93403161365e2e0.tar.gz
gentoo-2c94b2e8aadee9bcff10389bb93403161365e2e0.tar.bz2
gentoo-2c94b2e8aadee9bcff10389bb93403161365e2e0.zip
gnome-extra/nm-applet: Version bump
Package-Manager: portage-2.3.1
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-1.4.2.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.4.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-1.4.2.ebuild b/gnome-extra/nm-applet/nm-applet-1.4.2.ebuild
new file mode 100644
index 000000000000..63bd3b2b900a
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome2
+
+DESCRIPTION="GNOME applet for NetworkManager"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection modemmanager teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/dbus-glib-0.88
+ >=sys-apps/dbus-1.4.1
+ >=sys-auth/polkit-0.96-r1
+ >=x11-libs/gtk+-3.4:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ app-text/iso-codes
+ >=net-misc/networkmanager-1.3:=[introspection?,modemmanager?,teamd?]
+ net-misc/mobile-broadband-provider-info
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ virtual/freedesktop-icon-theme
+ virtual/libgudev:=
+ modemmanager? ( net-misc/modemmanager )
+ teamd? ( >=dev-libs/jansson-2.3 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+PDEPEND="virtual/notification-daemon" #546134
+
+src_configure() {
+ gnome2_src_configure \
+ --without-appindicator \
+ --disable-more-warnings \
+ --disable-static \
+ --localstatedir=/var \
+ $(use_enable introspection) \
+ $(use_with modemmanager wwan) \
+ $(use_with teamd team)
+}