summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-23 23:16:08 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-23 23:16:08 +0300
commit64d95d5427ac6f73569eb4e42701502942201134 (patch)
treebdb11ad6156834047345c9068f64dd6d74e305aa /gnome-extra/nm-applet/nm-applet-1.8.10.ebuild
parentdev-libs/libgee: bump to 0.20.1 (diff)
downloadgentoo-64d95d5427ac6f73569eb4e42701502942201134.tar.gz
gentoo-64d95d5427ac6f73569eb4e42701502942201134.tar.bz2
gentoo-64d95d5427ac6f73569eb4e42701502942201134.zip
gnome-extra/nm-applet: bump to 1.8.10
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-1.8.10.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.8.10.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-1.8.10.ebuild b/gnome-extra/nm-applet/nm-applet-1.8.10.ebuild
new file mode 100644
index 000000000000..d0c747da9362
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.8.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome2
+
+DESCRIPTION="GNOME applet for NetworkManager"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection gcr +modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-crypt/libsecret-0.18
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/dbus-glib-0.88
+ >=sys-apps/dbus-1.4.1
+ >=sys-auth/polkit-0.96-r1
+ >=x11-libs/gtk+-3.10:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+
+ app-text/iso-codes
+ >=net-misc/networkmanager-1.7:=[introspection?,modemmanager?,teamd?]
+ net-misc/mobile-broadband-provider-info
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ virtual/freedesktop-icon-theme
+ virtual/libgudev:=
+ gcr? ( >=app-crypt/gcr-3.14:=[gtk] )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.0
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+PDEPEND="virtual/notification-daemon" #546134
+
+src_configure() {
+ local myconf=(
+ --without-appindicator
+ --disable-lto
+ --disable-ld-gc
+ --disable-more-warnings
+ --disable-static
+ --localstatedir=/var
+ $(use_enable introspection)
+ $(use_with gcr)
+ $(use_with modemmanager wwan)
+ $(use_with selinux)
+ $(use_with teamd team)
+ )
+ gnome2_src_configure "${myconf[@]}"
+}