summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2019-01-06 13:07:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-24 22:14:38 +0200
commit31c29f64f190b810e41ebc23bc3736a2b70c591a (patch)
treedd50a7194ae870683ba7ea25b44ab989c733e2bc /gnome-extra/polkit-gnome
parentgames-strategy/widelands: Bump to version 0.20_rc1 (diff)
downloadgentoo-31c29f64f190b810e41ebc23bc3736a2b70c591a.tar.gz
gentoo-31c29f64f190b810e41ebc23bc3736a2b70c591a.tar.bz2
gentoo-31c29f64f190b810e41ebc23bc3736a2b70c591a.zip
gnome-extra/polkit-gnome: port to EAPI 7
Signed-off-by: Matija Skala <mskala@gmx.com> Closes: https://github.com/gentoo/gentoo/pull/10753 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'gnome-extra/polkit-gnome')
-rw-r--r--gnome-extra/polkit-gnome/polkit-gnome-0.105-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/polkit-gnome/polkit-gnome-0.105-r2.ebuild b/gnome-extra/polkit-gnome/polkit-gnome-0.105-r2.ebuild
new file mode 100644
index 000000000000..b271426d6e23
--- /dev/null
+++ b/gnome-extra/polkit-gnome/polkit-gnome-0.105-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org
+
+DESCRIPTION="A dbus session bus service that is used to bring up authentication dialogs"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/polkit"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.30
+ >=sys-auth/polkit-0.102
+ x11-libs/gtk+:3"
+RDEPEND="${DEPEND}
+ !lxde-base/lxpolkit"
+BDEPEND="dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS HACKING NEWS README TODO )
+
+src_install() {
+ default
+
+ cat <<-EOF > "${T}"/polkit-gnome-authentication-agent-1.desktop
+ [Desktop Entry]
+ Name=PolicyKit Authentication Agent
+ Comment=PolicyKit Authentication Agent
+ Exec=/usr/libexec/polkit-gnome-authentication-agent-1
+ Terminal=false
+ Type=Application
+ Categories=
+ NoDisplay=true
+ NotShowIn=MATE;KDE;
+ AutostartCondition=GNOME3 if-session gnome-fallback
+ EOF
+
+ insinto /etc/xdg/autostart
+ doins "${T}"/polkit-gnome-authentication-agent-1.desktop
+}