summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-05-01 19:27:59 +0300
committerMart Raudsepp <leio@gentoo.org>2017-05-01 19:36:47 +0300
commit8080a320f176677cd0df594172174c12ba836618 (patch)
tree50e280b12e8959447e36921a78413303da1c565e /gnome-extra/sushi/sushi-3.24.0.ebuild
parentwww-client/otter: [QA] Remove WANT_CMAKE (diff)
downloadgentoo-8080a320f176677cd0df594172174c12ba836618.tar.gz
gentoo-8080a320f176677cd0df594172174c12ba836618.tar.bz2
gentoo-8080a320f176677cd0df594172174c12ba836618.zip
gnome-extra/sushi: bump to 3.24.0
Small bug fixes and ensurance it doesn't break if gtk4 with introspection would be available. Thus nothing GNOME 3.24 specific really, and so not p.masked with the rest of GNOME 3.24. Fix libX11 dep to gtk+:3[X] as it actually is (at least in 3.24).
Diffstat (limited to 'gnome-extra/sushi/sushi-3.24.0.ebuild')
-rw-r--r--gnome-extra/sushi/sushi-3.24.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/sushi/sushi-3.24.0.ebuild b/gnome-extra/sushi/sushi-3.24.0.ebuild
new file mode 100644
index 000000000000..303c950aa0ba
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.24.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# gtk+[X] optionally needed for sushi_create_foreign_window(); when wayland is more widespread, might want to not force it
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[X,introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ media-libs/clutter-gst:3.0[introspection]
+ media-libs/musicbrainz:5=
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}