summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/sushi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest2
-rw-r--r--gnome-extra/sushi/metadata.xml9
-rw-r--r--gnome-extra/sushi/sushi-3.12.0.ebuild53
-rw-r--r--gnome-extra/sushi/sushi-3.16.0.ebuild52
4 files changed, 116 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
new file mode 100644
index 000000000000..f6130c443a86
--- /dev/null
+++ b/gnome-extra/sushi/Manifest
@@ -0,0 +1,2 @@
+DIST sushi-3.12.0.tar.xz 281976 SHA256 78594a858371b671671205e7b2518e7eb82ed8c2540b62f45a657aaabdf1a9ff SHA512 909cf9f820a1e78f1a74d08a152e6ad4713d25d4043be3c76739f73422764fbceb843ae083948cb1f7e7d862f011881087fe3ef4a4ee3afeeec47513bcf8dec2 WHIRLPOOL de3ddd9055ed664741846ab0de80d34803a0560d4ed5ecaaf2812d437d2f078dcae021cf8d3b6ebe68e3b38ae342b91b7dccb25b7391caed5477a7299e734b76
+DIST sushi-3.16.0.tar.xz 282588 SHA256 86c4e22b374514492334b5fcca6f170d328dae77cfcc0acd357c5426600b0034 SHA512 7938aa5457fa05f806c68ca28365a93236465737293fef1efa0a2435db6e95f347f0524a086435306ecb2a90fd9a93c2f01b2f6523afb5ddf8d2a6c1380e4165 WHIRLPOOL 76f154bc0a139c660cc23ca1d17c2b73344ce0ac274466286e885e004c7ef8939768bd2e473b1a6bfedc720f1dab85fd7d2be9869e31b79fe077bf588b9c0cb9
diff --git a/gnome-extra/sushi/metadata.xml b/gnome-extra/sushi/metadata.xml
new file mode 100644
index 000000000000..6923537f839f
--- /dev/null
+++ b/gnome-extra/sushi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="office">Support viewing file formats such as generated by
+ <pkg>app-office/libreoffice</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/gnome-extra/sushi/sushi-3.12.0.ebuild b/gnome-extra/sushi/sushi-3.12.0.ebuild
new file mode 100644
index 000000000000..834f65ddc349
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.4.0:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/clutter-gst:2.0[introspection]
+ media-libs/musicbrainz:5
+ net-libs/webkit-gtk:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ x11-themes/gnome-icon-theme-symbolic
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
diff --git a/gnome-extra/sushi/sushi-3.16.0.ebuild b/gnome-extra/sushi/sushi-3.16.0.ebuild
new file mode 100644
index 000000000000..d12b9ac7052a
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.16.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/clutter-gst:2.0[introspection]
+ media-libs/musicbrainz:5
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}