summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zeitgeist-datasources
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zeitgeist-datasources')
-rw-r--r--gnome-extra/zeitgeist-datasources/Manifest1
-rw-r--r--gnome-extra/zeitgeist-datasources/metadata.xml28
-rw-r--r--gnome-extra/zeitgeist-datasources/zeitgeist-datasources-0.8.1.ebuild109
3 files changed, 138 insertions, 0 deletions
diff --git a/gnome-extra/zeitgeist-datasources/Manifest b/gnome-extra/zeitgeist-datasources/Manifest
new file mode 100644
index 000000000000..61474eb122dc
--- /dev/null
+++ b/gnome-extra/zeitgeist-datasources/Manifest
@@ -0,0 +1 @@
+DIST zeitgeist-datasources-0.8.1.tar.gz 482395 SHA256 c7394f8e580a9607052b66e0db2d08643c062f3841122319c5b89a0ed6ecbc1e SHA512 a97872536f400f444f1bbff6af2b5dad91155f5d271b34a3c46fd6dbec203728694ec7bb79a431dea30299cb5ea19d8724988989189f9f87fa1274cacbe84fd5 WHIRLPOOL 9dbb2aebf32b8d0ad8691701eeefee70450b2866329a07a765309ea1c879f2f31c65011dfd3e8a749426afcf79f21d8878d435e02aca11b260f7e2f6f70aea0c
diff --git a/gnome-extra/zeitgeist-datasources/metadata.xml b/gnome-extra/zeitgeist-datasources/metadata.xml
new file mode 100644
index 000000000000..c7b89058a6d5
--- /dev/null
+++ b/gnome-extra/zeitgeist-datasources/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Dataproviders are small plugins for applications whose work is to push the
+user’s activities as events in the Zeitgeist daemon. The work of dataproviders
+are limited to pushing events and not consuming. Without dataproviders being
+enabled having exhaustive log of user’s activities is tough as Zeitgeist
+datahub does not track events like opening websites etc.
+</longdescription>
+ <use>
+ <flag name="bzr">Zeitgeist plugin for <pkg>dev-vcs/bzr</pkg> as data source</flag>
+ <flag name="geany">Zeitgeist plugin for <pkg>dev-util/geany</pkg> as data source</flag>
+ <flag name="vim">Zeitgeist plugin for vim as data source</flag>
+ <flag name="emacs">Zeitgeist plugin for emacs as data source</flag>
+ <flag name="tomboy">Zeitgeist plugin for <pkg>app-misc/tomboy</pkg> as data source</flag>
+ <flag name="telepathy">Zeitgeist plugin for telepathy framework as data source</flag>
+ <flag name="firefox">Zeitgeist plugin for <pkg>www-client/firefox</pkg> as data source</flag>
+ <flag name="chromium">Zeitgeist plugin for <pkg>www-client/chromium</pkg> as data source</flag>
+ <flag name="thunderbird">Zeitgeist plugin for <pkg>mail-client/thunderbird</pkg> as data source</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">zeitgeist-datasources</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnome-extra/zeitgeist-datasources/zeitgeist-datasources-0.8.1.ebuild b/gnome-extra/zeitgeist-datasources/zeitgeist-datasources-0.8.1.ebuild
new file mode 100644
index 000000000000..8907a4b4135c
--- /dev/null
+++ b/gnome-extra/zeitgeist-datasources/zeitgeist-datasources-0.8.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+VALA_MIN_API_VERSION=0.14
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils eutils mono-env multilib python-single-r1 versionator vala
+
+DIR_PV=$(get_version_component_range 1-2)
+DIR_PV2=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins whose work is to push activities as events into Zeitgeist daemon"
+HOMEPAGE="https://launchpad.net/zeitgeist-datasources/ http://zeitgeist-project.com/"
+SRC_URI="http://launchpad.net/zeitgeist-datasources/${DIR_PV}/${DIR_PV2}/+download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+PLUGINS_IUSE="bzr chromium emacs firefox geany mono telepathy thunderbird tomboy vim"
+PLUGINS="bzr chrome emacs firefox geany monodevelop telepathy thunderbird tomboy vim"
+IUSE="${PLUGINS_IUSE} static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libzeitgeist
+ x11-libs/gtk+:2
+ emacs? ( virtual/emacs )
+ firefox? ( || ( >=www-client/firefox-4.0 >=www-client/firefox-bin-4.0 ) )
+ geany? ( dev-util/geany )
+ mono? ( dev-util/monodevelop )
+ telepathy? (
+ net-libs/telepathy-glib[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ )
+ tomboy? (
+ app-misc/tomboy
+ dev-dotnet/gtk-sharp
+ dev-dotnet/mono-addins
+ dev-dotnet/zeitgeist-sharp
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ )
+ vim? ( app-editors/vim[python] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+PDEPEND="gnome-extra/zeitgeist"
+
+src_prepare() {
+ rm bzr/bzr-icon-64.png || die
+ sed \
+ -e '/bzr-icon-64.png/d' \
+ -i bzr/Makefile.am || die
+ sed \
+ -e '/^allowed_plugin/s:^:#:g' \
+ -i configure.ac || die
+
+ SEARCH='$(datadir)/opt/google/chrome/resources'
+ REPLACE="/usr/$(get_libdir)/chromium-browser/resources"
+ sed \
+ -e "s:${SEARCH}:${REPLACE}:" \
+ -i chrome/Makefile.* || die
+
+ sed \
+ -e "/^extensiondir/s:= .*:= \$(libdir)/firefox/extensions:g" \
+ -e "/^xul_extdir/s:xul-ext-zeitgeist:xpcom-firefox@zeitgeist-project.com:g" \
+ -i firefox/extension/Makefile.am || die
+
+ sed \
+ -e "/^extensiondir/s:= .*:= \$(libdir)/thunderbird/extensions:g" \
+ -e "/^xul_extdir/s:xul-ext-zeitgeist:thunderbird@zeitgeist-project.com:g" \
+ -i thunderbird/extension/Makefile.am || die
+
+ sed \
+ -e 's:vim72:vimfiles:' \
+ -i vim/Makefile.* || die
+
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local i myplugins
+
+ for i in ${PLUGINS}; do
+ case ${i} in
+ chrome )
+ use chromium && myplugins+=( ${i} )
+ ;;
+ monodevelop )
+ use mono && myplugins+=( ${i} )
+ ;;
+ * )
+ use ${i} && myplugins+=( ${i} )
+ ;;
+ esac
+ done
+
+ local myeconfargs=(
+ allowed_plugins="${myplugins[@]}"
+ )
+ autotools-utils_src_configure
+}