summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild')
-rw-r--r--gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild b/gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild
new file mode 100644
index 000000000000..e43cae75b727
--- /dev/null
+++ b/gnome-extra/zeitgeist-extensions/zeitgeist-extensions-0.0.13-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Allow manipulating events before/after insertion as well as before fetching"
+HOMEPAGE="https://launchpad.net/zeitgeist-extensions/"
+SRC_URI="http://launchpad.net/${PN}/trunk/fts-${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="fts geolocation memprofile sqldebug tracker"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ fts? (
+ !gnome-extra/zeitgeist[fts]
+ dev-libs/xapian-bindings[python]
+ dev-python/dbus-python
+ dev-python/pygobject
+ dev-python/pyxdg
+ )
+ geolocation? (
+ dev-python/dbus-python
+ dev-python/python-geoclue
+ )
+ memprofile? (
+ dev-python/dbus-python
+ dev-python/pympler
+ )
+ sqldebug? ( dev-python/python-sqlparse )
+ tracker? (
+ app-misc/tracker
+ dev-python/pygobject
+ dev-python/dbus-python
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python.patch \
+ "${FILESDIR}"/${P}-gobject.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_install() {
+ python_moduleinto /usr/share/zeitgeist/_zeitgeist/engine/extensions
+ use fts && python_domodule ./fts/fts.py
+ if use geolocation; then
+ dodoc ./geolocation/example.py
+ python_domodule ./geolocation/geolocation.py
+ fi
+ if use memprofile; then
+ python_domodule ./memory-profile/profile_memory.py
+ newdoc ./memory-profile/README README-memprofile
+ fi
+ use sqldebug && python_domodule ./debug_sql/debug_sql.py
+ use tracker && python_domodule ./tracker/tracker.py
+
+ python_optimize "${ED}"/usr/share/zeitgeist/_zeitgeist/engine/extensions
+}