summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zeitgeist/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zeitgeist/files')
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.14-gio-backport.patch18
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch29
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch38
3 files changed, 85 insertions, 0 deletions
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.14-gio-backport.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.14-gio-backport.patch
new file mode 100644
index 000000000000..178215ddbf13
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.14-gio-backport.patch
@@ -0,0 +1,18 @@
+From b1e82de434a7b63fe1290d0051de58350b069991 Mon Sep 17 00:00:00 2001
+From: Philip Withnall <philip@tecnocode.co.uk>
+Date: Sun, 16 Feb 2014 15:08:49 +0000
+Subject: libzeitgeist: Add a missing dependency on gio-2.0
+
+This actually makes the zeitgeist vapi file usable.
+
+Signed-off-by: Seif Lotfy <seif@lotfy.com>
+---
+diff --git a/libzeitgeist/zeitgeist-2.0.deps b/libzeitgeist/zeitgeist-2.0.deps
+index ff8d39b..59eec5d 100644
+--- a/libzeitgeist/zeitgeist-2.0.deps
++++ b/libzeitgeist/zeitgeist-2.0.deps
+@@ -1 +1,2 @@
+ zeitgeist-datamodel-2.0
++gio-2.0
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch
new file mode 100644
index 000000000000..857df8a11856
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch
@@ -0,0 +1,29 @@
+From 201bd67de450320520a12e2b0c465c8eb6818bd2 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Mon, 17 Mar 2014 20:57:49 +0100
+Subject: [PATCH] WhereClause: Fix array-length to work with string.joinv of
+ vala-0.24
+
+---
+ libzeitgeist/where-clause.vala | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libzeitgeist/where-clause.vala b/libzeitgeist/where-clause.vala
+index a830599..d981914 100644
+--- a/libzeitgeist/where-clause.vala
++++ b/libzeitgeist/where-clause.vala
+@@ -211,7 +211,11 @@ namespace Zeitgeist
+ */
+ private T[] generic_array_to_unowned_array<T> (GenericArray<T> gptrarr)
+ {
++#if VALA_0_24
++ long[] pointers = new long[gptrarr.length];
++#else
+ long[] pointers = new long[gptrarr.length + 1];
++#endif
+ Memory.copy(pointers, ((PtrArray *) gptrarr)->pdata,
+ (gptrarr.length) * sizeof (void *));
+ return (T[]) pointers;
+--
+2.3.0
+
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch
new file mode 100644
index 000000000000..79184f70a2ba
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch
@@ -0,0 +1,38 @@
+From dd46d6f8db69ee8d291d63251d841e73070cd526 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 4 Jan 2015 00:09:14 +0100
+Subject: [PATCH] Make python module detection match detected python
+
+Some distribution might provided multiple python and configure can know
+about which exactly though AM_PATH_PYTHON.
+---
+ configure.ac | 11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index acf7daa..6136ad6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -269,13 +269,14 @@ if test "x$HAVE_RAPPER" = "xno"; then
+ fi
+
+ # check for python-rdflib
++AM_PATH_PYTHON([2.7])
++
+ AC_MSG_CHECKING([for python-rdflib])
+-echo "import rdflib" | python - 2>/dev/null
+-if test $? -ne 0 ; then
+- AC_MSG_FAILURE([failed. Please install the python-rdflib package.])
+-else
++AS_IF([$PYTHON -c "import rdflib" 2>/dev/null], [
+ AC_MSG_RESULT([yes])
+-fi
++], [
++ AC_MSG_FAILURE([failed. Please install the python-rdflib package.])
++])
+
+ #################################################
+ # Summary
+--
+2.3.0
+