summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-25 08:34:59 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-25 08:02:37 -0500
commit3464ac33a57eb80848e38fd934528b77143065b8 (patch)
treedaf46f56a35773552aa1e6815f280766195c7450 /gnome-extra/zenity
parentnet-ftp/filezilla: add 3.63.0 (diff)
downloadgentoo-3464ac33a57eb80848e38fd934528b77143065b8.tar.gz
gentoo-3464ac33a57eb80848e38fd934528b77143065b8.tar.bz2
gentoo-3464ac33a57eb80848e38fd934528b77143065b8.zip
gnome-extra/zenity: Version bump to 3.44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29259 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.44.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 3e4d36e1e300..f6b2025387fb 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1 +1,2 @@
DIST zenity-3.42.1.tar.xz 3091752 BLAKE2B 7364ce9175efb7d4954956c1c2bd347ffd8060f02be3c21ec65525ee84e082eeffd8af3cb72b3f051f401a9ff90595c0a015223efcd96b6069e9bc3d276de16e SHA512 a8239e7dde351f3d3f75a59c95588f672c69333d4a53d50465d05fb73e61d1bbff6aca89acffc35a8d6802f465048ad2cbd7421bc3e3200a5a393ee3c9319106
+DIST zenity-3.44.0.tar.xz 3096684 BLAKE2B bd6cb333e30ca675bd6d49a8117fc81a8d5ffe2870b9d78f897f292b827849cfaee7d92d36ebc9dc784041400b221cca715d40878be0bb2f5aa47ccbf9c10965 SHA512 806fff8f239dfa5da32e75bbc1fc3a6dc50b49ea8e6ca64cead9dd40adfe4741237c25ae5caaac1997ec7f274e9379b6607d254caf8a509aa01f3eba03cb3e7c
diff --git a/gnome-extra/zenity/zenity-3.44.0.ebuild b/gnome-extra/zenity/zenity-3.44.0.ebuild
new file mode 100644
index 000000000000..9080ff54a435
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.44.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3[X]
+ >=dev-libs/glib-2.43.4:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4.1 )
+ x11-libs/libX11
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+src_configure() {
+ local emesonargs=(
+ $(meson_use libnotify)
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}