summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-11-21 10:10:20 -0300
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:54:04 +0100
commit4a30dc85e28fd0f3f2be80f1d63af8dd5612213d (patch)
treedfbb4f81e1ee016812bfff67e76db8368193328b /gnome-extra/zenity
parentmedia-sound/spek: drop 0.8.3-r1, 0.8.4 (diff)
downloadgentoo-4a30dc85e28fd0f3f2be80f1d63af8dd5612213d.tar.gz
gentoo-4a30dc85e28fd0f3f2be80f1d63af8dd5612213d.tar.bz2
gentoo-4a30dc85e28fd0f3f2be80f1d63af8dd5612213d.zip
gnome-extra/zenity: Version bump to 3.99.90
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33927 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.99.90.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 3b54b5f83663..7f4c71528322 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,3 +1,4 @@
DIST zenity-3.44.2.tar.xz 3095752 BLAKE2B 07d5b9aa673ae1e719bbd8d2ff85394ce19b9e77c36c3b6cf73d6b806dbcb0ab6322d13e66a715ebf5aefc14fa289a31367d0f0abd6ceaa9df7e3d7d12049492 SHA512 60f139b18db9ddf95a9c3481b08a3b99dd56ce457a49d99dc33f59570837e8498e8819bdd130c915a08e40042b2f3af583bd0fe4498adb8152632bd044137f2f
DIST zenity-3.99.1.tar.xz 3086092 BLAKE2B cf43be455f97e1ecf0539339d515415c9f875a5a0ac961f11b6e2fe463362eae400633628132ed67c67c01dd61a39cba2dc247ad3b82449d51867a9d93bda2c1 SHA512 4be34682da266b79e05e56a862e698bd93bb2187b4395b699be8ba63053dac07a0f9598bba411fb1f06dc2fffab78829a791f797e66665ada23d1eac3463b3a8
DIST zenity-3.99.2.tar.xz 3084880 BLAKE2B a6ae2a465516f2e019ad5bec5a4f5bad42dc499f85e5f293804d18c572a3f2dd69224ceb6dfc62156aaff587d8a4e78549e8cc88493c842a6ad056ce58c85920 SHA512 6130c01e34e74bd6d068cbd6d3c1e208fce73cbce61851482e0dbc5c24322953899b6de7859ed86fe89850a1650ad28f8815cf709c152c02a685725350260afb
+DIST zenity-3.99.90.tar.xz 3086228 BLAKE2B 7254447125019b309ef3466fd6f7fc935968395dbd4d506b69a8b80ea4e8150620f6e0647265dcb2023f9f28bb59a84d174d8563f4a9ba0a3598489931070e79 SHA512 7f1dbf9baa6960059eb7e973b175a2b4411b695d211fb3fc290bd393a75cdb201a440adb05fbe7f6a1d162d3b80a409c3b64573abb037b047a9a8c27c981e9a1
diff --git a/gnome-extra/zenity/zenity-3.99.90.ebuild b/gnome-extra/zenity/zenity-3.99.90.ebuild
new file mode 100644
index 000000000000..1f8292d3f4ef
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.99.90.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}