summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-11 08:48:16 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:43:08 +0200
commit08559816795ae384d618b5fc91a76e078c66b1e8 (patch)
treef7c98beef573ee54a6c26974225e1fcae9d98046 /gnome-extra
parentsys-kernel/gentoo-sources: Remove reference to deblob in metadata.xml (diff)
downloadgentoo-08559816795ae384d618b5fc91a76e078c66b1e8.tar.gz
gentoo-08559816795ae384d618b5fc91a76e078c66b1e8.tar.bz2
gentoo-08559816795ae384d618b5fc91a76e078c66b1e8.zip
gnome-base/nautilus: version bump 3.22.3 → 3.24.2.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-color-manager/Manifest1
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/gnome-color-manager/Manifest b/gnome-extra/gnome-color-manager/Manifest
index d98210782a3c..f2c472dc29ba 100644
--- a/gnome-extra/gnome-color-manager/Manifest
+++ b/gnome-extra/gnome-color-manager/Manifest
@@ -1 +1,2 @@
DIST gnome-color-manager-3.22.2.tar.xz 2671864 SHA256 e837a184e66a6a5fb778730a58d3aa8d3a10a447e13f48efc86cac7e4c94d45b SHA512 dd50cff841fc8e70554c0c998494e363b709d1a8d4084dfc8daca6297d9491c1b797c4f3f106284e0f8ef133ac77704ad805b5519566c2f49e311f30a1e8397f WHIRLPOOL 188bf45db1e7713fdf884d35ce6274a65a9d4f338a428b4555ba8d09b75d9f907b60377d8bcc355f0afe9ad93ae106f2d0eeb4a49150112f2d476883e60990dc
+DIST gnome-color-manager-3.24.0.tar.xz 2857120 SHA256 a1009e6287d97b8d1fdd6e44a4c8668bcf05f1bb7f2186243318e54c6d061dd2 SHA512 e145caf4e885ea6e9c4ee5a5b4d800d70af338e26d3bfcda81e20c6144e36d0581638d07099302d30787d6d30e9d58f2b8373f6585ae3788df825d6d24f5b003 WHIRLPOOL 9882c9610a93fe5eb82f8ba66a559b7675cf4902ba5129b94dc3ad19f6c7d37aaabe8cb753957959587f04d6f0d89c7598a46cd30274c27c7ead331873917215
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
new file mode 100644
index 000000000000..55f0c58e4624
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.24.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 virtualx
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="packagekit raw"
+
+# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331
+RDEPEND="
+ >=dev-libs/glib-2.31.10:2
+ >=media-libs/lcms-2.2:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ media-libs/libexif
+ media-libs/tiff:0=
+
+ >=x11-libs/gtk+-3.3.8:3
+ >=x11-libs/vte-0.25.1:2.91
+ >=x11-misc/colord-1.3.1:0=
+ >=x11-libs/colord-gtk-0.1.20
+
+ packagekit? ( app-admin/packagekit-base )
+ raw? ( media-gfx/exiv2 )
+"
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Always enable tests since they are check_PROGRAMS anyway
+ # appstream does not want to be relax by default !
+ gnome2_src_configure \
+ --disable-static \
+ --enable-tests \
+ $(use_enable packagekit) \
+ $(use_enable raw exiv)
+# APPSTREAM_UTIL=$(type -P true)
+}
+
+src_test() {
+ virtx emake check
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version media-gfx/argyllcms ; then
+ elog "If you want to do display or scanner calibration, you will need to"
+ elog "install media-gfx/argyllcms"
+ fi
+}