summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-13 00:20:58 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-13 01:14:57 +0200
commit2a1a914e4e6b68d23845a3ccb4b11db6d4b165af (patch)
treee88e7576e563a0d516d524f838c34d03e4d53cda /gnome-extra
parentgnome-extra/gnome-weather: cleanup old revisions (diff)
downloadgentoo-2a1a914e4e6b68d23845a3ccb4b11db6d4b165af.tar.gz
gentoo-2a1a914e4e6b68d23845a3ccb4b11db6d4b165af.tar.bz2
gentoo-2a1a914e4e6b68d23845a3ccb4b11db6d4b165af.zip
gnome-extra/zenity: 3.22.0 → 3.24.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.24.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index dcba621708bd..43c6effab8c1 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1 +1,2 @@
DIST zenity-3.22.0.tar.xz 1082088 SHA256 1ecdfa1071d383b373b8135954b3ec38d402d671dcd528e69d144aff36a0e466 SHA512 0131e854ffb8093e6c36787ffc831af8d1adbb663931b09b86a477c28c3b456ad2c9bb59cdc00a2d6505a1cf645df6fc9ebdd3c46c1a666c69d607e79b4364a3 WHIRLPOOL 02369c5e8721faf23bd247d308d243b5a2f85c3493b6b5e4708fec84a5db9284fb374a9573875d664569978e14eeb8f3a175a9b614eb496a42c173fddeb75a02
+DIST zenity-3.24.0.tar.xz 1085124 SHA256 6ff0a026ec94e5bc1b30f78df91e54f4f82fd982f4c29b52fe5dacc886a9f7f7 SHA512 b24291166221cc2dabeabfeab7ca00ca63ff21c12a4eb327cd35ac43f485b8d4a858dd717df1b35b8bd3fd89d0bb235609855c6d349b76879b0f77b4fedd4dd9 WHIRLPOOL 723e8434ce355edeffa6f0ac541520c1fce676b76f83a11e16a2ee73430386e2676ab0cf7f867ab7706fe87e91dbe55024edcd319333102215031a0ea7453bac
diff --git a/gnome-extra/zenity/zenity-3.24.0.ebuild b/gnome-extra/zenity/zenity-3.24.0.ebuild
new file mode 100644
index 000000000000..43e2f2019e2a
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.24.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3[X]
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}