summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 20:42:36 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 21:00:06 -0500
commit2fb6695c7e284333024f0b9203dc4c2fef49b9a4 (patch)
tree8d1e3a4f5f45c215f7b3660ad7c3813a07064d33 /gnome-extra
parentnet-misc/modemmanager: Version bump to 1.18.4 (diff)
downloadgentoo-2fb6695c7e284333024f0b9203dc4c2fef49b9a4.tar.gz
gentoo-2fb6695c7e284333024f0b9203dc4c2fef49b9a4.tar.bz2
gentoo-2fb6695c7e284333024f0b9203dc4c2fef49b9a4.zip
gnome-extra/nm-applet: Version bump to 1.24.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nm-applet/Manifest1
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.24.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/Manifest b/gnome-extra/nm-applet/Manifest
index 57e083f977f1..09188ac2ede3 100644
--- a/gnome-extra/nm-applet/Manifest
+++ b/gnome-extra/nm-applet/Manifest
@@ -1 +1,2 @@
DIST network-manager-applet-1.22.0.tar.xz 1901680 BLAKE2B e1597d5ee332000082e2939745af10f5f5d5e9177b388f67fdb9822636226502a4c96f4f97187f01ae8de5bd1b4d853670e94dc9058e9b31cf9cadf11fe6a64b SHA512 80c9a8df750f1253a66aea254f30278a934ed4e11fecff03cfa50a31da9efcff5c8892caef672a4d62d8c5c473770358c35344b49a9f3d7956ad76063b794cac
+DIST network-manager-applet-1.24.0.tar.xz 1903280 BLAKE2B a969ab18e2d2d85d378d9964e635281cfcd4bc46e0542ec94e187cbe7e740c5fad8e10b3d7d3ae3b85352ba5368787650f933b89740d05ee06d78057e1c31712 SHA512 7b91bd54d53b1b485bc5e401f83c683804175900557a7a4bc40a3f759fa9d4ca1c42b193bcd56a39a8cb79ec5b0c6f7cbeccfc08200099c08d933650c92faecb
diff --git a/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild
new file mode 100644
index 000000000000..769fc0bab392
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="NetworkManager connection editor and applet"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="appindicator modemmanager selinux teamd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=app-crypt/libsecret-0.18
+ >=net-libs/libnma-1.8.27
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libgudev-147:=
+ >=x11-libs/libnotify-0.7.0
+ >=net-misc/networkmanager-1.16:=[modemmanager?,teamd?]
+ appindicator? (
+ dev-libs/libappindicator:3
+ >=dev-libs/libdbusmenu-16.04.0
+ )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7:= )
+
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dappindicator=$(usex appindicator ubuntu no)
+ $(meson_use modemmanager wwan)
+ $(meson_use selinux)
+ $(meson_use teamd team)
+ -Dmore_asserts=0
+ -Dld_gc=false
+ )
+ meson_src_configure
+}