summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2018-11-12 20:35:54 +0400
committerMichał Górny <mgorny@gentoo.org>2019-04-19 14:52:17 +0200
commit3d78ce7f7d4173f0cd57b958a5702ac5a63e44ec (patch)
tree456697932a81853fb24b5cf5793556f1d9894128 /gnome-extra
parentgames-kids/tuxtype: update HOMEPAGE, SRC_URI, metadata (diff)
downloadgentoo-3d78ce7f7d4173f0cd57b958a5702ac5a63e44ec.tar.gz
gentoo-3d78ce7f7d4173f0cd57b958a5702ac5a63e44ec.tar.bz2
gentoo-3d78ce7f7d4173f0cd57b958a5702ac5a63e44ec.zip
gnome-extra/chrome-gnome-shell: properly support firefox-bin.
www-client/firefox-bin is built on Debian host which doesn't have /usr/lib{32,64}, so it expects native host manifest in /usr/lib. With this change native host manifest will be additionally installed in /usr/lib when needed. Closes: https://bugs.gentoo.org/643522 Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Closes: https://github.com/gentoo/gentoo/pull/10401 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild
new file mode 100644
index 000000000000..5e66e29d6797
--- /dev/null
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
+SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-misc/jq
+ sys-apps/coreutils
+"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ gnome-base/gnome-shell
+"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXTENSION=OFF )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if [[ $(get_libdir) != "lib" && "${SYMLINK_LIB}" != yes ]]; then
+ # Workaround www-client/firefox-bin manifests location
+ # Bug: https://bugs.gentoo.org/643522
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ doins "${ED}"/usr/$(get_libdir)/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
+ fi
+}
+
+pkg_postinst() {
+ elog "Please note that this package provides native messaging connector only."
+ elog "You can install browser extension using link provided at"
+ elog "https://extensions.gnome.org website."
+}