summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-16 01:57:04 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-16 01:57:04 +0200
commit6cb50024b23c43fa0506c112685e5d09a0ede872 (patch)
treed10351be2debba93dacf90c306ebbfe85d597ac1 /gnome-extra
parentmedia-plugins/gst-plugins-srtp: carry ~alpha keyword forward (diff)
downloadgentoo-6cb50024b23c43fa0506c112685e5d09a0ede872.tar.gz
gentoo-6cb50024b23c43fa0506c112685e5d09a0ede872.tar.bz2
gentoo-6cb50024b23c43fa0506c112685e5d09a0ede872.zip
gnome-extra/gnome-shell-extensions-topicons-plus: bump to v22 for gnome-shell-3.30 compat
This extension is in practice not maintained upstream anymore, and is at a technical dead end for wayland (can't work). Some alternatives to research might be: https://extensions.gnome.org/extension/615/appindicator-support/ https://extensions.gnome.org/extension/1497/topicons-redux/ (as a maintained version of X11 topicons) Meanwhile lets have an upgraded version that at least will continue to work on GNOME 3.30 X11 sessions. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-22.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
index 3e9df732185c..068aed77eadc 100644
--- a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extensions-topicons-plus-21.tar.gz 2756641 BLAKE2B 39414711365a9c68fa2b0172859e9969a7f71eae5e7498abee9ff05e4c215df09419cdad99192c60892b1bd6e8b27724c81c5d3da9a3d8ca3072d984824cb950 SHA512 f85db46f20c24f0b11ce2c79c0548b88262faf059d674073e328917dc8497de0e07ccd6f3613f45aa9e49109468d78293f3a8f0f4fea5a24a7c5254666cda5df
+DIST gnome-shell-extensions-topicons-plus-22.tar.gz 2757811 BLAKE2B 8bfe719d4a0e4d58db9b21d354e841ea69b88d82c69ba6aa4ebc8db65acde9330553487d0a0d3b623d5a6a2a18ff67e6ad4e45133c6e7b8a77e07bd90c589e63 SHA512 f0589bd8ed6697d616772ab374e9aa80779512d38c50f82c375820c02c06ef26a50b2a8c78c4e5fab5dc8588ed5fdcf0b7e73e7868af0855545528e741aa280d
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-22.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-22.ebuild
new file mode 100644
index 000000000000..fb983644952d
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ # Assuming it needs only compiled gettext catalogs at runtime
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/locale"/*/LC_MESSAGES/*.po || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}