summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-09 11:14:19 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-11 13:46:22 +0100
commit7a97ebd4d1dd42b296dd433d669a35bd28dca133 (patch)
treeeb8c20db42323f42968b5d17b561608edb45dd9f /gnome-extra
parentwww-client/epiphany: add epiphany-3.22.2.ebuild (diff)
downloadgentoo-7a97ebd4d1dd42b296dd433d669a35bd28dca133.tar.gz
gentoo-7a97ebd4d1dd42b296dd433d669a35bd28dca133.tar.bz2
gentoo-7a97ebd4d1dd42b296dd433d669a35bd28dca133.zip
gnome-extra/gucharmap: add gucharmap-9.0.2.ebuild
Simple bump, no relevant changes https://git.gnome.org/browse/gucharmap/diff/?id=9.0.2&&id2=9.0.1 Closes: https://github.com/gentoo/gentoo/pull/2788 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-9.0.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 331776f0b6c8..114fbd8d2471 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -3,3 +3,4 @@ DIST gucharmap-3.16.2.tar.xz 1996036 SHA256 0a3fa996ae271c8f4812a7d8dc573ece0c00
DIST gucharmap-3.18.2.tar.xz 2031560 SHA256 80141d3e892c3c4812c1a8fad8f89978559ef19e933843267e6e9a5524c09ec9 SHA512 d12eefb56272192762086271aa65bfa8b9a8843ac68a6affa1af3d2c891227b0fdae1c274976ceb883ecce26b7d9a2b28c2712155650c0969d6da77b1ff482b5 WHIRLPOOL 176e29627e33e28e965d07efe94aac1c1110bc2c44603c7220d34e520b36a443f73bfc823a395f48760023e137980a822e49c701910813e9deb280b8be115d38
DIST gucharmap-9.0.0.tar.xz 1007252 SHA256 d698ce4bba5486f7e32e9a4ec0ecd916926fb876640856746121d8ae8012765c SHA512 6054a392d719ebdb98205cb451b6971ca2ddc9d83b2de8b25412b0a561143d5ddb5b4fa0174ae997697b28dc79d60f477208bc6a112cb06346b250aa90e78fd7 WHIRLPOOL 1004ba7f5db5ced3e11cefc1ff61d3f7c05536de77f9a42520959183be9c6592e2ad93f3976750d277514c88d71d1c003035a275c33142c78a458d5f4f59fda6
DIST gucharmap-9.0.1.tar.xz 1022516 SHA256 8617ab68f2977cc3780a1f39264a48b8d9cf8824172c442fa9ca1c11d81dbd6c SHA512 66aabfe9253247816f9f8a603f0151a44b0b60e04b20875322b71345539da444d72d1f1b4551fa04ab03cdbc2d6638d9126c5d48bb7604994dc532ca165152e2 WHIRLPOOL 5d2cf83fee3103ae5fc555ece7c59c9cbf7d2d74d659128809eb41ac58170e611184cacb87557b7194fa2dc500202a818fe73d3cb38d00d80e341faa02a15515
+DIST gucharmap-9.0.2.tar.xz 1023120 SHA256 723ea92c8e877beae3986432b8e002807c6c2d1140590dff1c5bff34bb6ed265 SHA512 33fa2989e263ba30bc430b8181009dd5d491dd2b453f6047369dc49dafb4f58be67dd9f1320b7005325236519a794eb4564fbd39a1d976133001f4f983ae1370 WHIRLPOOL 2119761dddc9cfc6288aaca282ed37e299c30c772cbaa86e699421a9de077ebb1b35540254098a7f47f26fc1aea704c7900f3caf32fc23d8bb96a1f31b0f0ffc
diff --git a/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild b/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
new file mode 100644
index 000000000000..69d3b806093c
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=app-i18n/unicode-data-9.0.0
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gucharmap-3:0
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # prevent file collisions with slot 0
+ sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # unihan is not really conditional
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210#c5
+ gnome2_src_configure \
+ --disable-static \
+ --with-unicode-data=/usr/share/unicode-data \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}