summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-06 09:09:29 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-06 13:04:25 +0200
commit9401cba1dfdd620c2d64fe9be92d510d5daf074b (patch)
tree3690e6559d8e75cc5816a15a9007a6dfd2b4cd55 /gnome-extra
parentnet-libs/nodejs: Version 10.15.3 (diff)
downloadgentoo-9401cba1dfdd620c2d64fe9be92d510d5daf074b.tar.gz
gentoo-9401cba1dfdd620c2d64fe9be92d510d5daf074b.tar.bz2
gentoo-9401cba1dfdd620c2d64fe9be92d510d5daf074b.zip
gnome-extra/gnome-system-monitor: bump to 3.28.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index eb609dd5452e..764692d2aae9 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST gnome-system-monitor-3.24.0.tar.xz 930956 BLAKE2B f08b6da2ee9d45d232f1d1f019b6844f6fcf50baf85944d240611fbc0794cce6755d6b7daf275f4d97686558fc0f2525a8700fda473b576f8d5d41f66f118275 SHA512 4155d9f130cc1e38d32b76d10ca91056d82b90ca555f9ded26acfd1ef018b92163b0cc2256861b8e166b3bfa7eadc6c900aa9c79fd0c859045197ab2eaf3dc9f
DIST gnome-system-monitor-3.26.0.tar.xz 941144 BLAKE2B bde11ed78b10140916121df49af36b04afc6d9cb35fc1fa4f240ab8c109b79bfce5175d0e91e7a80c6da5420e13ca2aa520e76db9b79ea08d5dab23fcd8a301a SHA512 c2593371d956a4c11ad9ac4afabc996c02d743f9ba443192b0d955ab42464a02ad3fe19398b9489d33d552fdfdc2fb615e85d4dcb9342b821cb0b590fd3c3043
+DIST gnome-system-monitor-3.28.2.tar.xz 1209156 BLAKE2B 6b23617ce1168eb1144affee0a7234fb7a86cc94cdf8220ce56c685604392db24359b4870238a7e96cd6a6e72b3130d77dd34c7cfa240c4c650b936d7ba42335 SHA512 8c55e97174c7334b19b8d9ef171d3dc97bdb2de4fb8442471e55ae6a0bbf0608e78eee3aafefda8a4a0375b804e5332dce692f3bd6676b4b623aa5be4c87b948
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild
new file mode 100644
index 000000000000..87e551af3204
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.55.0:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+ systemd? ( >=sys-apps/systemd-44:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X broken-wnck) \
+ APPDATA_VALIDATE="$(type -P true)"
+}