summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-15 10:19:22 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-15 11:01:04 +0200
commit9ba0375bd5c78b51de9dfa4b4ab408cc49e211d7 (patch)
tree676fb0357eddd63248d05881f7eb878801ffb630 /gnome-extra
parentgnome-extra/evolution-data-server: Drop old (diff)
downloadgentoo-9ba0375bd5c78b51de9dfa4b4ab408cc49e211d7.tar.gz
gentoo-9ba0375bd5c78b51de9dfa4b4ab408cc49e211d7.tar.bz2
gentoo-9ba0375bd5c78b51de9dfa4b4ab408cc49e211d7.zip
gnome-extra/evolution-data-server: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.20.5.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
index 33f9b254d58e..b245e95e4627 100644
--- a/gnome-extra/evolution-data-server/Manifest
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -1,2 +1,3 @@
DIST evolution-data-server-3.18.5.tar.xz 5414416 SHA256 a897c789925e86df31a1c78212b431cca13dc4d5a3d87e1fb3d507df3994e8e1 SHA512 10b17b771dbb55ad8320b742d96f6d720f3245bed24fdc415027df6920b0847afa89eb839cd5d4613c0ec40972634c7c695e4ea0ce819973eab0de99987c253e WHIRLPOOL 3c95f43113882409bf85b8f97d49cea74e857ce4c562b625b0936bd014b0799ea16b6c7d2d9c0c0cdbd1f6ce7daf509c15d6413b26f275050da30030a5f0d2a3
DIST evolution-data-server-3.20.4.tar.xz 5068932 SHA256 f250e3ccb8b6308086f330a1766b235a9d2643ae3e170384eb6391316d0b080e SHA512 51cf71dfb8fc36d91a698006d068e63d3937a8c503329e4d8af62ec914ab6702805eb9c9f11a7c4569f5357eba4a8322f1c017919f5267a318ce15d12185234f WHIRLPOOL 26dec9733aa9479da18fdbde8716dfdb44f56f15dae17a7b8e38e9b995b88b62042cf655791b4a6d24eae378e4f71a2c10b7f79e34886f41d9b7b3242d0d98ed
+DIST evolution-data-server-3.20.5.tar.xz 5067732 SHA256 0d1586cd326d997497a2a6fddd939a83892be07cb20f8c88fda5013f8c5bbe7e SHA512 8376331ae0ee96013d5c61b1da92393486d0eb9e0fed63199d4b6c28d92cb6d9dc45826fd65b476d894141d507742e8574168bc99b8704bebe8b39bbd297606e WHIRLPOOL 3c3417603bd2a18c7a3370e32af7f1581fc399ebe6f721d0ac678a5978d667b58df2927eb02f240b4c2f139133e06f25e13a47879b7b7a470cd1283a186bba10
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.20.5.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.20.5.ebuild
new file mode 100644
index 000000000000..d33f3eeb302c
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.20.5.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+VALA_USE_DEPEND="vapigen"
+
+inherit db-use flag-o-matic gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/57" # subslot = libcamel-1.2 soname version
+
+IUSE="api-doc-extras berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+
+# sys-libs/db is only required for migrating from <3.13 versions
+# gdata-0.15.1 is required for google tasks
+# berkdb needed only for migrating old calendar data, bug #519512
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libgdata-0.10:=
+ >=dev-libs/libical-0.43:=
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.42:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.10:3
+ )
+ google? (
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libgdata-0.15.1:=
+ >=net-libs/webkit-gtk-2.4.9:3
+ )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/gperf
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2
+
+# Some tests fail due to missings locales.
+# Also, dbus tests are flacky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ # phonenumber does not exist in tree
+ gnome2_src_configure \
+ $(use_enable api-doc-extras gtk-doc) \
+ $(use_with api-doc-extras private-docs) \
+ $(usex berkdb --with-libdb="${EPREFIX}"/usr --with-libdb=no) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable gtk) \
+ $(use_enable google google-auth) \
+ $(use_enable google) \
+ $(use_enable introspection) \
+ $(use_enable ipv6) \
+ $(use_with kerberos krb5 "${EPREFIX}"/usr) \
+ $(use_with kerberos krb5-libs "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_with ldap openldap) \
+ $(use_enable vala vala-bindings) \
+ $(use_enable weather) \
+ --enable-largefile \
+ --enable-smime \
+ --without-phonenumber \
+ --disable-examples \
+ --disable-uoa
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset SESSION_MANAGER
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym /usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}