summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-08 23:21:53 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-10 00:27:35 +0100
commitb99c18e53139853f539ef70544bf6facda7aaaa3 (patch)
tree8fffe752a58122bbcac113c2ddc3bc66d4d09b74 /gnome-extra
parentgames-puzzle/swell-foop: add swell-foop-3.22.2.ebuild (diff)
downloadgentoo-b99c18e53139853f539ef70544bf6facda7aaaa3.tar.gz
gentoo-b99c18e53139853f539ef70544bf6facda7aaaa3.tar.bz2
gentoo-b99c18e53139853f539ef70544bf6facda7aaaa3.zip
gnome-extra/gnome-system-monitor: add gnome-system-monitor-3.22.2.ebuild
Simple bump, no relevant changes https://git.gnome.org/browse/gnome-system-monitor/diff/?id=3.22.2&&id2=3.22.0 Closes: https://github.com/gentoo/gentoo/pull/2785 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.22.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index e94ae0414048..03370b0fd4d5 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST gnome-system-monitor-3.20.1.tar.xz 895800 SHA256 9b23ab443fd92050b95c03a0ab321bbd41696a0ffc89c06e79c8798dca0a44f9 SHA512 ad01d947ac027c2483be6c44e7a890be8da7f0473cc5e9237aa01f3f0570a2144c15dbd12287dbb905a3c128319b15ff2e11198aa132946974b0ea6f4ada07e9 WHIRLPOOL d27d462fd8f389e96c41bf3876c652e57130c665fabae234f789e42f88d6c8eb3e1db7280191f5d269243ab81794598898b7169101dd8fc284edc424d66d9001
DIST gnome-system-monitor-3.22.0.tar.xz 912112 SHA256 4339d36c2f7b702652ee03424a241f855992c583bb437d7083c61d8dcfe3fff8 SHA512 8b41b1a46e72185dce48ae7083db8ee9c77a94fe45a2fe715e4e15762b59076decadb1775640880aaadcadff9e381d5eb36c18fce8e8445b14b89b62e1f1b186 WHIRLPOOL 6b1a42bb63eeede233330c377e394312e67b691439138163a40c34607088a72eac6ffd6a98706f03acd3d1f21006217ac57237b6c314193ca1a5f97b4cf19f0d
+DIST gnome-system-monitor-3.22.2.tar.xz 907524 SHA256 68a5b097157a6e445fc2467cbaecfede77d00b774c93e8aa69b6f784055dc982 SHA512 ff713efc63a8b5f247c27358f69fcb8b27d631fb242bddc6a819b453996f7c49ba8a883bd3dc38437dccd227cbf393e473226d597af0994f25f4ca3246707d13 WHIRLPOOL 7362895dbdae5bbe365e1db7e951eae10d75dda2bddf51281a13df79c4adb7a8d48b3f34c71af33d227cc6e3250c4f465118c1dc2067ef11b8d3ae96738481a5
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.22.2.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.22.2.ebuild
new file mode 100644
index 000000000000..bd407999eaad
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.22.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2=
+ >=x11-libs/gtk+-3.12:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+ systemd? ( >=sys-apps/systemd-44:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.41.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # XXX: appdata is deprecated by appstream-glib, upstream must upgrade
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck) \
+ APPDATA_VALIDATE="$(type -P true)"
+}