summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-27 14:27:08 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-27 14:39:49 +0200
commitec808adda217d07bb554a784bd644c90abe472aa (patch)
treec492e2ae46a97433caba0a7369fb0efc9091d6f4 /gnome-extra
parentgnome-extra/evolution-data-server: fix libgdata enabling logic, backport a patch (diff)
downloadgentoo-ec808adda217d07bb554a784bd644c90abe472aa.tar.gz
gentoo-ec808adda217d07bb554a784bd644c90abe472aa.tar.bz2
gentoo-ec808adda217d07bb554a784bd644c90abe472aa.zip
gnome-extra/evolution-ews: add patch for SSL certificate validation
Bug: https://bugs.gentoo.org/678070 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.30.5-r1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 50b612b11a09..b16448aff335 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,4 @@
DIST evolution-ews-3.24.6.tar.xz 488668 BLAKE2B 3ec507b654042882158d2d8dfdbaae0372cc67d515501e45e327ef006cd8674f7b6e48de63f8930add9f29536d3428604f21666cfac98a764cb2eb0c20353ef3 SHA512 24bcaf9755b9d45d4848624b42f2b41bf1532aa836cdd26f8ab57b4dd5ac83d4375c340e0cac6f7f1b830c3ab998597893bce0fdd471ed7b0758a69367edfac1
DIST evolution-ews-3.26.6.tar.xz 485624 BLAKE2B 7e9b13fff05122a54fe502d0d4bd1f0ba895259b89d074d9f39ab4e56bdd2794e780c61023294ceea79adb94f80a42a232e4cc1743c41b062c1b03c9276a6253 SHA512 eeee228699989d0407ed65d2b8fa37f643890b40084484a125738dc9a10152de435cbc9e3109c1aa5ae90daeb4aba6e06da135c84d7f7e0fd330f5d8448383ee
+DIST evolution-ews-3.30.5-certificate-validation.patch.xz 6928 BLAKE2B eb1f070797231f14cc71cce2f19a0dc925edc0f67eca9267568c835e878d9f1567aaad7dd8a14c88abb047af8db8220239c78d62387329c9d38e5c5eda21822b SHA512 2d4fa5f9c24bf92ab4e5105cc5d265907e8af760d7c969ffdf74d090795948e1f9e0e84f5d051c2a6c4324ed49cc2c23f23ebdccf67fa8baab965c612ad807e6
DIST evolution-ews-3.30.5.tar.xz 525252 BLAKE2B 510666cdf6bdb95e73799256daa9b4c753ed70de71798d3acb73eb55c30158a7b6b56fe7617150ec0a1f5ce20676da8a3ab4608fca06f009ea16fbc234770736 SHA512 6b17fd73b461e0ddd725ee87c854fca45fbc14f10922a60aff5a9a25b56728f1f16a0d3196b4bc3cba83e75655c15244c3bf2442fa17449c7466ab95371e93d7
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.30.5-r1.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.30.5-r1.ebuild
new file mode 100644
index 000000000000..ff16e76e2080
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.30.5-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-certificate-validation.patch.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ dev-libs/libical:0=
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}-r1:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.42:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( net-libs/uhttpmock )
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+src_prepare() {
+ eapply "${WORKDIR}"/${P}-certificate-validation.patch # requires patch added in eds 3.30.5-r1
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}