summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-07-29 19:42:34 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-07-29 19:42:51 +0200
commitb93e8cbf7122c2cedfb899e0bc2fa6653eac7e95 (patch)
tree571bd14e0aaffa2002a332675fa3ad77d9dfc02f /gnustep-apps
parentgnustep-libs/sope: 4.3.2 bump (diff)
downloadgentoo-b93e8cbf7122c2cedfb899e0bc2fa6653eac7e95.tar.gz
gentoo-b93e8cbf7122c2cedfb899e0bc2fa6653eac7e95.tar.bz2
gentoo-b93e8cbf7122c2cedfb899e0bc2fa6653eac7e95.zip
gnustep-apps/sogo: 4.3.2 bump
This builds with -fcommon until we have proper fix Thanks Nabucho for testing this version Closes: https://bugs.gentoo.org/725630 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/sogo-4.3.2.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index 86d4b4b6568c..0edcabd1a94f 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1 +1,2 @@
DIST sogo-4.1.1.tar.gz 34492410 BLAKE2B 43c15991eede15b58d22681297d7d2d8031ee189e4b843af7c44e52a915d89d30c181dc52c25e4784b0e9011f5d6f22bf070b9125491fe37360ced2b623c0f86 SHA512 e24d4b7f71eeed05dcb694ee07a03df6ac9a63d7fb9455f972add9c251f85e1418683a95de5b584b0db3a471d593c8595b343db1345fcb95235ba59a09235d5a
+DIST sogo-4.3.2.tar.gz 34497548 BLAKE2B fd9e225488bbdb13b4204d1cec9ba0217049681d531e20db3d995a4928f0cd8ff658eb390a0f84375ee28fec2c7a36fb11d836939a8731e828be8d38728a6559 SHA512 eeae11c2e9c4f3d38e64ebdac4950980859af6486e229d1480c9ceb895b63229b42ceea9a17934bfd5e88c5f05c93567f5df5f29f7d68b7dafcdfc44054bc9af
diff --git a/gnustep-apps/sogo/sogo-4.3.2.ebuild b/gnustep-apps/sogo/sogo-4.3.2.ebuild
new file mode 100644
index 000000000000..4c79d63dc156
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-4.3.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnustep-2 vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="activesync gnutls libressl +ssl"
+
+RDEPEND="
+ acct-user/sogo
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ activesync? ( dev-libs/libwbxml )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die
+ if use activesync; then
+ sed -e 's/Tests\/Unit/ActiveSync &/g' \
+ -i GNUmakefile || die
+ fi
+
+ # Temporarily build with -fcommon for gcc 10
+ # Bug 725630
+ echo 'ADDITIONAL_OBJCFLAGS += -fcommon' >> general.make
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+ if use activesync; then
+ ewarn "In order to use the SOGo ActiveSync support code in production environments,"
+ ewarn "you need to get a proper usage license. Check the documentation for details."
+ fi
+}