summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-01-09 17:15:22 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-01-09 17:27:11 +0100
commitd3b0b8d8a4e66db2fc9d25e0d93097081f5b7309 (patch)
tree90cc9f96c1fb06df45b9b68d0dc6763da0b211f2 /gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild
parentgnustep-base/gnustep-gui: 0.26.2 bump (diff)
downloadgentoo-d3b0b8d8a4e66db2fc9d25e0d93097081f5b7309.tar.gz
gentoo-d3b0b8d8a4e66db2fc9d25e0d93097081f5b7309.tar.bz2
gentoo-d3b0b8d8a4e66db2fc9d25e0d93097081f5b7309.zip
gnustep-base/gnustep-back-cairo: 0.26.2 bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild')
-rw-r--r--gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild
new file mode 100644
index 000000000000..bce99c6bd9d1
--- /dev/null
+++ b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.26.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnustep-base
+
+DESCRIPTION="Cairo back-end component for the GNUstep GUI Library"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl xim"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ =gnustep-base/gnustep-gui-${PV%.*}*
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=media-libs/freetype-2.1.9
+
+ >=x11-libs/cairo-1.2.0[X]
+
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-xlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+src_configure() {
+ egnustep_env
+
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=cairo"
+
+ econf $myconf
+}