summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:12:37 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:13 +0000
commit4fde3f6303157ee2406dbbf31c2d5577f77c164b (patch)
treeec4885d1b650a011a40d141677d5ddb5b717d378 /gnustep-base
parentgames-puzzle/zaz: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-4fde3f6303157ee2406dbbf31c2d5577f77c164b.tar.gz
gentoo-4fde3f6303157ee2406dbbf31c2d5577f77c164b.tar.bz2
gentoo-4fde3f6303157ee2406dbbf31c2d5577f77c164b.zip
gnustep-base/gnustep-base: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
index 650cd7372bb6..ac7e08a85e0a 100644
--- a/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
+++ b/gnustep-base/gnustep-base/gnustep-base-1.27.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils gnustep-base
+inherit eutils gnustep-base toolchain-funcs
DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
HOMEPAGE="http://www.gnustep.org"
@@ -38,7 +38,7 @@ src_configure() {
local myconf
if use libffi ; then
- myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$($(tc-getPKG_CONFIG) --variable=includedir libffi)"
else
myconf="--disable-libffi --enable-ffcall"
fi