summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:37:17 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:55 +0100
commite4c922278affe8fcc7ee2d90910f60d7c0a4e7ce (patch)
tree82148d96a82ebf6393105125b3544f5ec9b60c18 /gnustep-base
parentgames-util/higan-purify: respect ${PKG_CONFIG} (diff)
downloadgentoo-e4c922278affe8fcc7ee2d90910f60d7c0a4e7ce.tar.gz
gentoo-e4c922278affe8fcc7ee2d90910f60d7c0a4e7ce.tar.bz2
gentoo-e4c922278affe8fcc7ee2d90910f60d7c0a4e7ce.zip
gnustep-base/mknfonts: respect ${PKG_CONFIG}, depend on pkgconfig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/mknfonts/files/mknfonts-0.5-pkgconfig.patch9
-rw-r--r--gnustep-base/mknfonts/files/mknfonts-rename.patch4
-rw-r--r--gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild10
3 files changed, 12 insertions, 11 deletions
diff --git a/gnustep-base/mknfonts/files/mknfonts-0.5-pkgconfig.patch b/gnustep-base/mknfonts/files/mknfonts-0.5-pkgconfig.patch
index e73bac5c1ddf..f375b0277dc2 100644
--- a/gnustep-base/mknfonts/files/mknfonts-0.5-pkgconfig.patch
+++ b/gnustep-base/mknfonts/files/mknfonts-0.5-pkgconfig.patch
@@ -1,14 +1,13 @@
-diff -Naur mknfonts-0.5.orig/GNUmakefile mknfonts-0.5/GNUmakefile
---- mknfonts-0.5.orig/GNUmakefile 2002-09-28 12:27:26.000000000 +0200
-+++ mknfonts-0.5/GNUmakefile 2018-06-29 11:27:01.871588321 +0200
+--- a/GNUmakefile
++++ b/GNUmakefile
@@ -9,8 +9,8 @@
ADDITIONAL_OBJCFLAGS += -Wall -O2
-ADDITIONAL_INCLUDE_DIRS += `freetype-config --cflags`
-ADDITIONAL_LDFLAGS += `freetype-config --libs`
-+ADDITIONAL_INCLUDE_DIRS += `pkg-config --cflags freetype2`
-+ADDITIONAL_LDFLAGS += `pkg-config --libs freetype2`
++ADDITIONAL_INCLUDE_DIRS += `${PKG_CONFIG} --cflags freetype2`
++ADDITIONAL_LDFLAGS += `${PKG_CONFIG} --libs freetype2`
mknfonts_OBJC_FILES = mknfonts.m
diff --git a/gnustep-base/mknfonts/files/mknfonts-rename.patch b/gnustep-base/mknfonts/files/mknfonts-rename.patch
index e62618b7844c..426d7c92640b 100644
--- a/gnustep-base/mknfonts/files/mknfonts-rename.patch
+++ b/gnustep-base/mknfonts/files/mknfonts-rename.patch
@@ -1,5 +1,5 @@
---- mknfonts-0.5/mknfonts.m.orig 2007-05-03 11:46:27.000000000 +0200
-+++ mknfonts-0.5/mknfonts.m 2007-05-03 11:47:34.000000000 +0200
+--- a/mknfonts.m
++++ b/mknfonts.m
@@ -310,12 +310,6 @@
{
fi=[faceinfos objectAtIndex: i];
diff --git a/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
index af4957771143..b0aa579764ee 100644
--- a/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
+++ b/gnustep-base/mknfonts/mknfonts-0.5-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnustep-base
+inherit gnustep-base toolchain-funcs
DESCRIPTION="A tool to create .nfont packages for use with gnustep-back-art"
HOMEPAGE="https://packages.debian.org/mknfonts.tool"
@@ -15,8 +15,8 @@ IUSE=""
RDEPEND="gnustep-base/gnustep-gui
>=media-libs/freetype-2.1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-rename.patch
@@ -26,6 +26,8 @@ PATCHES=(
src_prepare() {
default
+ tc-export PKG_CONFIG
+
# Correct link command for --as-needed
sed -i -e "s/ADDITIONAL_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die
}