summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-02-17 11:35:11 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-02-17 11:39:52 +0100
commita3911cf802a625fb1d674553730f1f9ed8ef4a29 (patch)
tree98951d5058ad0e37d7295f885c3d4204fc1ab6a3 /gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild
parentgnustep-libs/performance: version bump (diff)
downloadgentoo-a3911cf802a625fb1d674553730f1f9ed8ef4a29.tar.gz
gentoo-a3911cf802a625fb1d674553730f1f9ed8ef4a29.tar.bz2
gentoo-a3911cf802a625fb1d674553730f1f9ed8ef4a29.zip
gnustep-libs/sqlclient: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild')
-rw-r--r--gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild b/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild
new file mode 100644
index 000000000000..0a4e91d0d7af
--- /dev/null
+++ b/gnustep-libs/sqlclient/sqlclient-1.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit java-pkg-opt-2 gnustep-2
+
+MY_P=${P/sqlc/SQLC}
+DESCRIPTION="GNUstep lightweight database abstraction layer"
+HOMEPAGE="http://wiki.gnustep.org/index.php/SQLClient"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="java mysql postgres +sqlite"
+
+RDEPEND=">=gnustep-libs/performance-0.3.2
+ mysql? ( virtual/mysql:= )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( >=dev-db/sqlite-3 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( java mysql postgres sqlite )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ local myconf=""
+ use java || myconf="${myconf} --disable-jdbc-bundle"
+ use mysql || myconf="${myconf} --disable-mysql-bundle"
+ use postgres || myconf="${myconf} --disable-postgres-bundle"
+ use sqlite || myconf="${myconf} --disable-sqllite-bundle"
+
+ egnustep_env
+ econf ${myconf}
+}