summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-03 10:01:21 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-03 10:01:21 +0300
commit8fb68e8fdef4ca5b8b23592c073f2a09ad70dd07 (patch)
tree92012d9413b8508d13e367e6c03b0483bf6a5e01 /gnustep-libs
parentgnustep-apps/sogo: remove libressl support (diff)
downloadgentoo-8fb68e8fdef4ca5b8b23592c073f2a09ad70dd07.tar.gz
gentoo-8fb68e8fdef4ca5b8b23592c073f2a09ad70dd07.tar.bz2
gentoo-8fb68e8fdef4ca5b8b23592c073f2a09ad70dd07.zip
gnustep-libs/sope: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/sope/sope-4.1.1.ebuild14
-rw-r--r--gnustep-libs/sope/sope-4.3.2.ebuild14
2 files changed, 6 insertions, 22 deletions
diff --git a/gnustep-libs/sope/sope-4.1.1.ebuild b/gnustep-libs/sope/sope-4.1.1.ebuild
index a24c86a95657..7feec1b83046 100644
--- a/gnustep-libs/sope/sope-4.1.1.ebuild
+++ b/gnustep-libs/sope/sope-4.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,15 +12,14 @@ SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.t
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
+IUSE="gnutls ldap mysql postgres +ssl +xml"
RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
+ dev-libs/openssl:0=
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
@@ -28,13 +27,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-pkg_pretend() {
- if use ssl && use gnutls && use libressl ; then
- ewarn "You have enabled both gnutls and libressl, but only"
- ewarn "one provider can be active. Using gnutls!"
- fi
-}
-
src_configure() {
local ssl_provider
if use ssl ; then
diff --git a/gnustep-libs/sope/sope-4.3.2.ebuild b/gnustep-libs/sope/sope-4.3.2.ebuild
index 81e7c8a4a03a..7feec1b83046 100644
--- a/gnustep-libs/sope/sope-4.3.2.ebuild
+++ b/gnustep-libs/sope/sope-4.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,15 +12,14 @@ SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.t
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
+IUSE="gnutls ldap mysql postgres +ssl +xml"
RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
+ dev-libs/openssl:0=
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
@@ -28,13 +27,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-pkg_pretend() {
- if use ssl && use gnutls && use libressl ; then
- ewarn "You have enabled both gnutls and libressl, but only"
- ewarn "one provider can be active. Using gnutls!"
- fi
-}
-
src_configure() {
local ssl_provider
if use ssl ; then