summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <meurerbernardo@gmail.com>2019-08-03 20:33:09 -0700
committerAaron Bauman <bman@gentoo.org>2019-08-08 20:12:32 -0400
commit264467e31b7139e731ccbf277812b7652e96f6c6 (patch)
tree5bf11c935cea1da5e897018c4fa62a8d260288c1 /gui-apps/grim/grim-1.2.0.ebuild
parentprofiles/arch/ia64/package.use.mask: sys-apps/rng-tools -jitterentropy (diff)
downloadgentoo-264467e31b7139e731ccbf277812b7652e96f6c6.tar.gz
gentoo-264467e31b7139e731ccbf277812b7652e96f6c6.tar.bz2
gentoo-264467e31b7139e731ccbf277812b7652e96f6c6.zip
gui-apps/grim: New package (1.2.0, 9999)
Closes: https://bugs.gentoo.org/684712 Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Closes: https://github.com/gentoo/gentoo/pull/12613 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/grim/grim-1.2.0.ebuild')
-rw-r--r--gui-apps/grim/grim-1.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/grim/grim-1.2.0.ebuild b/gui-apps/grim/grim-1.2.0.ebuild
new file mode 100644
index 000000000000..c8c932c13aa2
--- /dev/null
+++ b/gui-apps/grim/grim-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo
+"
+RDEPEND="
+ ${DEPEND}
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}