summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <meurerbernardo@gmail.com>2019-08-29 10:41:46 -0700
committerDavid Seifert <soap@gentoo.org>2019-09-12 10:50:45 +0200
commitc9edf97dbd6921790ba5650882eab7f1d7348ef4 (patch)
tree3bc1a74e9edfa3b0e886aaec90bc23e0fe570206 /gui-apps/waybar/waybar-0.8.0.ebuild
parentsys-apps/sysvinit: Removed old (diff)
downloadgentoo-c9edf97dbd6921790ba5650882eab7f1d7348ef4.tar.gz
gentoo-c9edf97dbd6921790ba5650882eab7f1d7348ef4.tar.bz2
gentoo-c9edf97dbd6921790ba5650882eab7f1d7348ef4.zip
gui-apps/waybar: bump 0.8.0
Closes: https://bugs.gentoo.org/693084 Closes: https://github.com/gentoo/gentoo/pull/12809 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'gui-apps/waybar/waybar-0.8.0.ebuild')
-rw-r--r--gui-apps/waybar/waybar-0.8.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gui-apps/waybar/waybar-0.8.0.ebuild b/gui-apps/waybar/waybar-0.8.0.ebuild
new file mode 100644
index 000000000000..64cd54c2c498
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )
+"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_use libcxx)
+ )
+ meson_src_configure
+}